RebarLengthAdjustmentDataNullable Class

The RebarLengthAdjustmentDataNullable class defines the length adjustment at the end of a reinforcing bar affected by a RebarEndDetailModifier. If a length adjustment property is null then that property will not be applied to the RebarSet generated reinforcing bars.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarLengthAdjustmentDataNullable

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarLengthAdjustmentDataNullable

The RebarLengthAdjustmentDataNullable type exposes the following members.

Constructors
  NameDescription
Public methodRebarLengthAdjustmentDataNullable
Initializes a new instance of the RebarLengthAdjustmentDataNullable class.
Top
Properties
  NameDescription
Public propertyAdjustmentLength
Gets or sets the adjustment length.
Public propertyAdjustmentType
Gets or sets the adjustment type.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next