DimensionSetBaseAttributesDimensionExaggerationAttributes Class

The DimensionExaggerationAttributes class handles attributes related to the exaggeration of dimension lines.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionExaggerationAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DimensionExaggerationAttributes : GenericAttributesBase

The DimensionSetBaseAttributesDimensionExaggerationAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyExaggerationDirection
The ExaggerationDirection.
Public propertyExaggerationEnabled
Exaggeration is enabled if the value is true.
Public propertyExaggerationHeight
The ExaggerationHeight.
Public propertyExaggerationOrigin
The ExaggerationOrigin.
Public propertyExaggerationPosition
The ExaggerationPosition.
Public propertyExaggerationWidth
The ExaggerationWidth.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next