Matrix Class

The Matrix class represents a 4x3 matrix.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dMatrix

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Matrix

The Matrix type exposes the following members.

Constructors
  NameDescription
Public methodMatrix
Creates a new indentity matrix.
Public methodMatrix(Matrix)
Creates a new matrix which is a copy of the given matrix.
Top
Properties
  NameDescription
Public propertyItem
Sets or gets the matrix element values.
Top
Methods
  NameDescription
Public methodGetTranspose
Returns a new matrix which is a transpose of the current matrix. The transposed matrix is an inversion of the current matrix, if the current matrix was a valid rotation matrix.
Public methodToString
Returns a string that represents the current matrix.
(Overrides ObjectToString.)
Public methodTransform(IEnumerablePoint)
Transforms the given points using the current matrix.
Public methodTransform(Point)
Transforms the given point using the current matrix.
Public methodTranspose
Transposes a matrix. The resulting matrix is an inversion of the current matrix, if the current matrix was a valid rotation matrix.
Top
Operators
  NameDescription
Public operatorStatic memberMultiply(Matrix, IEnumerablePoint)
Transforms the given points using the given matrix.
Public operatorStatic memberMultiply(Matrix, Matrix)
Multiplies (combines) two transformation matrices.
Public operatorStatic memberMultiply(Matrix, Point)
Transforms the given point using the given matrix.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next