SymbolElement Class

The SymbolElement class represents a symbol in the Tekla Structures symbol library.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SymbolElement : ElementBase

The SymbolElement type exposes the following members.

Constructors
  NameDescription
Public methodSymbolElement
Creates a new symbol element instance with the default symbol.
Public methodSymbolElement(SymbolInfo)
Creates a new symbol element instance with the given symbol.
Public methodSymbolElement(SymbolInfo, DrawingColors, Double)
Creates a new symbol element instance with the given symbol, color and height.
Top
Properties
  NameDescription
Public propertyColor
The symbol color.
Public propertyHeight
The symbol height (mm).
Public propertySymbol
The symbol.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next