Tekla.Structures.Model Namespace

The Tekla.Structures.Model namespace includes the functionality to insert, select, modify or delete objects inside a Tekla Structures model. The namespace also includes possibilites to query different kind of data from the current model instance, such as information about the currently selected objects. The namespace offers the functionality through .NET remoting and the COM interface.
Classes
  ClassDescription
Public classCode exampleAssembly
The Assembly class defines a single manufacturing unit: objects that are bolted or welded together in the workshop. An assembly has a main part and secondary assemblables attached to it. The number of secondaries is limited to 2048. Hierarchical assemblies can also have subassemblies attached to them and they can have a parent assembly instance.
Public classBaseComponent
The BaseComponent class is an abstract base class that represents generic components. The generic components derived from the base component are the component, the connection, the detail and the seam.
Public classCode exampleBasePoint
The BasePoint class provides base point related functionalities. Base points can be retrieved using ProjectInfo class.
Public classBaseRebarGroup
The BaseRebarGroup class is an abstract base class that represents reinforcing bar group classes. The reinforcing bar groups derived from the base group are the rebar group, the circled rebar group and the curved rebar group.
Public classBaseRebarModifier
Represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it.
Public classBaseWeld
The BaseWeld abstract class defines a weld between two model objects.
Public classCode exampleBeam
The Beam class represents a single beam in the model. A beam has a single start and end point.
Public classBendSurface
The BendSurface class defines a surface contour that can be used as a bend between two plates
Public classBendSurfaceNode
The BendSurfaceNode class represents a bend surface geometry tree node.
Public classCode exampleBentPlate
A class for the bent plate
Public classCode exampleBentPlateGeometrySolver
BentPlateGeometrySolver is a solver class to handle ConnectiveGeometry modification related computations.
Public classCode exampleBoltArray
The BoltArray class defines a bolt group with an array shape.
Public classCode exampleBoltCircle
The BoltCircle class defines a bolt group with a circle shape.
Public classBoltGroup
The BoltGroup class is an abstract base class for all bolt shapes, such as array, circle and XY list. See the Tekla Structures help file for further information about the attributes.
Public classBoltHoleAttributes
The bolt hole attributes.
Public classCode exampleBoltXYList
The BoltXYList class defines a bolt group with an XY list shape. The bolt group is the most generic one of the bolt groups.
Public classBoolean
The Boolean class is an abstract base class for boolean operations such as a part cut, an add, a fitting or a cut plane.
Public classCode exampleBooleanPart
The BooleanPart class represents a part cut or an add. This means that a model object is, for example, cut with a part instance to create a void to the father part. Typically the operative part is deleted after the boolean cut operation. In case of boolean add, operative part is deleted automatically.
Public classCode exampleBrep
The Brep class represents a single brep in the model. A brep has a single start and end point.
Public classCode exampleChamfer
The Chamfer class defines how the corners of a polybeam or a contour plate are rounded.
Public classChangeData
The ChangeData class presents information about the detected change of the modelobject in the model. It is instantiated inside the connected method.
Public classCode exampleCircleRebarGroup
The CircleRebarGroup class represents a group of reinforcing bars which have a circular shape.
Public classClashCheckData
The ClashCheckData class presents information about the detected clash. It is instantiated inside the onClashDetected method. The objects store the identifiers and type of the clash to be passed on to event subscribers.
Public classCode exampleClashCheckHandler
The ClashCheckHandler class contains clash check methods.
Public classCode exampleComponent
The Component class represents a component. A component is a modelling tool that typically assembles multiple parts to build some type of a structure, for example a hall macro or at a smaller scale a reinforcement component (a macro). Also, a custom part is a component.
Public classCode exampleComponentInput
The ComponentInput class handles the input of component objects and positions. A component has one component input. The component input must include all the needed input objects and points in the correct order. For example, an input with a point and a part is different from an input of a part and a point. The maximum number of different input items in the collection is 10.
Public classConicalSurface
The ConicalSurface class defines a conical surface contour.
Public classConicalSurfaceNode
The ConicalSurfaceNode class represents conical surface geometry tree node.
Public classCode exampleConnection
The Connection class represents a connection. A connection is something that connects two or more parts together.
Public classCode exampleConnectiveGeometry
A class for geometry formed of several geometry sections. Geometry is initialized with polygon geometry and then can be extended by calling one of AddLeg methods using BentPlateGeometrySolver class. In the case of success, two polygon geometries will be connected by cylindrical surface geometry possibly with help of additional polygon geometries. Resulted geometry, then, can be set to bent plate.
Public classConnectiveGeometryException
The ConnectiveGeometryException class represents an error that occurred during the ConnectiveGeometry creation or modification.
Public classContour
The Contour class defines a possibly chamfered contour. Contours must not have loops.
Public classCode exampleContourPlate
The ContourPlate class represents a part made with a contour, such as, a concrete slab.
Public classContourPoint
The ContourPoint class defines a point with possible chamfering information, used, for example, to define a contour plate.
Public classControlArc
The ControlArc class defines a user defined arc helping in modeling work.
Public classCode exampleControlCircle
The ControlCircle class defines a user defined (not magnetic) circle helping in modeling work. If there are duplicated input points or 3 input points are in a line, ControlCircle.Insert() will return false. ControlCircle.Select() will return the center point of the circle to Point1.
Public classCode exampleControlLine
The ControlLine class defines a user defined (possibly magnetic) line helping in modeling work.
Public classCode exampleControlPlane
The ControlPlane class defines a user defined (possibly magnetic) plane helping in modeling work.
Public classCode exampleControlPoint
The ControlPoint class defines a user defined point helping in modeling work.
Public classControlPolycurve
The ControlPolycurve class defines a user defined polycurve object which contains a chain of line and arc geometries.
Public classCode exampleCurvedRebarGroup
The CurvedRebarGroup class represents a group of reinforcing bars which have a curved shape.
Public classCode exampleCustomPart
The CustomPart class represents a custom part object in the Tekla Structures model. A custom part is a modeling tool that typically assembles multiple parts to build some type of a beam-like structure, for example a tapered beam or a sandwich panel.
Public classCode exampleCutPlane
The CutPlane class defines how the end of a part is cut with a plane. A cut plane differs from a fitting because a cut can never extend the boundaries of the original part.
Public classCylindricalSurface
The CylindricalSurface class defines a cylindrical surface contour.
Public classCylindricalSurfaceNode
The CylindricalSurfaceNode class represents cylindrical surface geometry tree node.
Public classCode exampleDeformingData
The DeformingData class holds information about the deforming of parts. Deformed parts are parts that have been warped, cambered or shortened.
Public classCode exampleDetail
The Detail class represents a detail. A detail is different from a connection since the detail only connects to one part.
Public classCode exampleDisposableToken
IDisposable delegate adapter.
Public classCode exampleEdgeChamfer
The EdgeChamfer class defines how the part edge is chamfered.
Public classCode exampleEvents
The Events class allows the user to register event listeners for model events.
Public classExtensionIntersectsWithPlateException
The ExtensionIntersectsWithPlateException class represents an error when extension plate clashes with plates.
Public classFacePerpendicularToIntersectionLineException
The FacePerpendicularToIntersectionLineException class represents an error when, face perpendicular to intersection line.
Public classFacesAtAnObtuseAngleException
The FacesAtAnObtuseAngleException class represents an error when, faces to be connected are too steep of an angle.
Public classFacesTooNearEachOtherException
The FacesTooNearEachOtherException class represents an error when, faces to be connected overlap.
Public classCode exampleFitting
The Fitting class defines how the part end fits to a plane. A fitting can make the part either longer or shorter.
Public classGeneralConnectiveGeometryException
The GeneralConnectiveGeometryException class represents a general error that occurred during the ConnectiveGeometry creation or modification.
Public classGeometrySection
The GeometrySection class represents geometry node with its identifier.
Public classGeometrySectionEnumerator
The GeometrySectionEnumerator class is used to enumerate the geometry sections of a bent plate geometry.
Public classCode exampleGrid
The Grid class defines a user defined (possibly magnetic) set of planes helping in modeling work. A grid has grid plane instances as children.
Public classCode exampleGridBase
The GridBase class defines the base class for grids.
Public classCode exampleGridCylindricalSurface
The GridCylindricalSurface class defines a user defined (possibly magnetic) cylindrical surface helping in modeling work. A grid cylindrical surface must always belong to a parent grid instance.
Public classCode exampleGridPlane
The GridPlane class defines a user defined (possibly magnetic) plane helping in modeling work. A grid plane must always belong to a father grid instance.
Public classGridSurface
The GridSurface class defines a user defined (possibly magnetic) surface helping in modeling work. A grid surface must always belong to a parent GridBase instance.
Public classCode exampleHierarchicDefinition
The HierarchicDefinition class defines a hierarchy structure. This hierarchy structure can be instantiated and extended by hierarchical objects.
Public classCode exampleHierarchicObject
The HierarchicObject class defines an object in a tree-structured hierarchy. The hierarchy structure is defined by hierarchical definitions which the hierarchical objects instantiate. Hierarchical objects may contain other hierarchical objects, thus forming a sub-hierarchy, or model objects.
Public classInputItem
The InputItem class is used to store input objects and positions.
Public classInvalidCurveCombinationException
This class represent an exception thrown when the combination of base curves is not allowed in a lofted plate operation
Public classInvalidFacePointsException
The InvalidFacePointsException class represents an error when, cannot create geometry from requested face points.
Public classInvalidRadiusException
The InvalidRadiusException class represents an error when, cannot connect parts with a cylindrical section having the provided radius.
Public classLoad
The Load class is an abstract base class for all loads.
Public classCode exampleLoadArea
The LoadArea class defines a linearly-distributed force bound by a triangle or a quadrangle.
Public classCode exampleLoadGroup
The LoadGroup class implements grouping functionality related to all loads. Each load should be assigned to a load group. Each load group contains loads caused by the same action and to which you want to refer collectively.

Tekla Structures assumes that all loads in a group

  • Have the same partial safety and other combination factors
  • Have the same action direction
  • Occur at the same time and all together

You may create new load groups, modify existing ones and delete load groups via the .NET interface. You may also change the assigned load group of a load and list all the load groups found in the model via the ModelObjectSelector interface. The model always has at least one load group.

Public classCode exampleLoadLine
The LoadLine class defines a linearly-distributed force or torsion.
Public classCode exampleLoadPoint
The LoadPoint class defines a concentrated force or a bending moment.
Public classCode exampleLoadTemperature
The LoadTemperature class defines a temperature change in a part, or a temperature difference between two part surfaces.
Public classCode exampleLoadUniform
The LoadUniform class defines a uniformly-distributed force bounded by a polygon.
Public classCode exampleLoftedPlate
This class represents a lofted plate
Public classLoftedPlateOperationException
This empty class serves as a base (marker class) for all the exception thrown in lofted plate operations
Public classCode exampleLogicalWeld
The LogicalWeld class represents a group of welds in the model. A logical weld contains a list of children welds. The primary properties need to be the same in all the children welds.
Public classCode exampleMaterial
The Material class represents a single material that parts can be made of.
Public classModel
The Model class represents a single model open in Tekla Structures. Before interaction with the model, the user will have to create one instance of this class.
Public classCode exampleModelHandler
The ModelHandler class provides information about the currently open Tekla Structures model.
Public classCode exampleModelInfo
The ModelInfo class provides information about the currently open Tekla Structures model.
Public classCode exampleModelObject
The ModelObject class is an abstract base class for all model objects, such as parts, bolts, welds and reinforcements.
Public classCode exampleModelObjectEnumerator
The ModelObjectEnumerator class provides the means to iterate through model object instances in the current model.
Public classCode exampleModelObjectSelector
The ModelObjectSelector class can be used to make different model object selections from the current model.
Public classNullRulingException
This class represent an exception thrown when a ruling of the lofted plate (i.e. the lines that swipe the plate surface between the base curves) would become zero because of a lofted plate operation
Public classNumberingSeries
The NumberingSeries class describes how an object is to be numbered.
Public classNumberingSeriesNullable
The NumberingSeriesNullable class describes how an object is to be numbered.
Public classObject
The Object class is an abstract base class for all the objects Tekla Structures has.
Public classCode exampleOffset
The Offset class defines the offset value of start points and end points. The offset is the distance from the current work plane in the three global directions.
Public classPart
The Part class represents a part in the model. A part can be either a beam, a polybeam or a contour plate.
Public classCode examplePhase
The Phase class defines a model object phase.
Public classCode examplePhaseCollection
The PhaseCollection class handles the collection of the model phases.
Public classCode examplePlane
The Plane class defines a plane in space using an origin, an X-axis and a Y-axis.
Public classPlateIntersectsWithIntersectionLineException
The PlateIntersectsWithIntersectionLineException class represents an error when, plate polygon extends beyond intersection line.
Public classPointCloud
Initializes a new instance of the PointCloud class.
Public classCode examplePolyBeam
The PolyBeam class represents a continuous beam with a contour as input.
Public classPolygon
The Polygon class represents a polygon object that has its corners at the given points.
Public classPolygonNode
The PolygonNode class represents flat geometry tree node.
Public classCode examplePolygonWeld
The PolygonWeld class represents a polygon weld in the model. A polygon weld has a main part and a secondary part.
Public classPolymesh
The Polygon class represents a polygon object that has its corners at the given points.
Public classPolymeshEnumerator
The PolymeshEnumerator class is used to enumerate the polymesh of a pour's merged faces.
Public classCode examplePosition
The Position class defines how a part is positioned relative to the input.
Public classCode examplePourBreak
The PourBreak class represents a pour break in a model.
Public classCode examplePourObject
The PourObject class represents a pour object in the model.
Public classCode examplePourUnit
The PourUnit class represents a pour unit in the model.
Public classProfile
The Profile class defines the form of a cross section.
Public classCode exampleProjectInfo
The ProjectInfo class provides project information about the currently open Tekla Structures model.
Public classCode exampleRadialGrid
The RadialGrid class defines a user defined (possibly magnetic) set; radial grid has grid planes and cylindrical grid planes as children
Public classCode exampleRebarComplexGeometry
The ReinforcingBar class represents a single physical reinforcing bar. It contains the curves and bendings that define the geometry of the bar.
Public classRebarCranking
The RebarCranking class represents the cranking of reinforcing bars at a RebarSplitter.
Public classRebarCrankingNullable
The RebarCrankingNullable class represents the cranking of reinforcing bars at a RebarEndDetailModifier.
Public classCode exampleRebarEndDetailModifier
The RebarEndDetailModifier class represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it. It can modify reinforcing bar end properties and will therefore affect the end of the reinforcing bars it is nearest to.
Public classCode exampleRebarGeometry
The RebarGeometry class represents a single physical reinforcing bar - the building block of a mesh, a rebar group and even a single rebar. It contains the physical reinforcing bar points in 3D space.
Public classCode exampleRebarGroup
The RebarGroup class represents a group of reinforcing bars.
Public classRebarGuideline
Defines a rebar guideline that is used in a RebarSet. A RebarSet has a minimum of one rebar guideline, the primary guideline.
Public classRebarHookData
The RebarHookData class defines the hook at the end of a reinforcing bar. Hooks are used for anchoring purposes.
Public classRebarHookDataNullable
The RebarHookDataNullable class defines the hook at the end of a reinforcing bar. Hooks are used for anchoring purposes.
Public classRebarLapping
The RebarLapping class represents the lapping of reinforcing bars at a RebarSplitter.
Public classRebarLeg
This represents a leg of a rebar and is used in the RebarComplexGeometry class.
Public classRebarLegFace
Defines a rebar leg face that is used in a RebarSet. Rebar leg faces control how the RebarSet generates the reinforcing bars.
Public classCode exampleRebarLegSurfaceObject
The RebarLegSurfaceObject class represents a polymesh surface for generating rebar legs in a RebarSet.
Public classRebarLengthAdjustmentDataNullable
The RebarLengthAdjustmentDataNullable class defines the length adjustment at the end of a reinforcing bar affected by a RebarEndDetailModifier. If a length adjustment property is null then that property will not be applied to the RebarSet generated reinforcing bars.
Public classCode exampleRebarMesh
The RebarMesh class represents a reinforcement mesh.
Public classRebarProperties
The RebarProperties class defines the default properties of the reinforcing bars in a RebarSet.
Public classRebarPropertiesNullable
The RebarPropertiesNullable class defines the properties of the reinforcing bars affected by a RebarPropertyModifier.
Public classCode exampleRebarPropertyModifier
The RebarPropertyModifier class represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it.
Public classCode exampleRebarSet
The RebarSet class represents a set of reinforcing bars.
Public classCode exampleRebarSetAddition
The RebarSetAddition class can be used to add RebarLegFace objects to an existing RebarSet.
Public classRebarSpacing
The RebarSpacing class defines spacing properties for a RebarGuideline.
Public classRebarSpacingExactSpacing
This class defines objects used in the exact spacing type.
Public classRebarSpacingZone
The RebarSpacingZone class defines the properties of a single spacing zone. The spacing properties of number of spaces, spacing and length are proposed properties that the spacing algorithm uses as input when calculating the final reinforcing bars spacing. Depending on the RebarSpacingZone properties and any other rebar spacing zones defined on the associated RebarGuideline the spacing algorithm may determine a different final reinforcing bars spacing from the original proposed properties. However the RebarSpacingZone properties will always contain the original proposed values.
Public classCode exampleRebarSplice
The RebarSplice class represents a splice between two reinforcements.
Public classCode exampleRebarSplitter
The RebarSplitter class represents a modifier that can split the RebarSet reinforcing bars that pass through it.
Public classCode exampleRebarStrand
The RebarStrand class represents prestressed strands for concrete parts.
Public classRebarThreadingDataNullable
The RebarThreadingDataNullable class defines the threading properties at the end of a reinforcing bar affected by a RebarEndDetailModifier. If a threading property is null then that property will not be applied to the RebarSet generated reinforcing bars.
Public classCode exampleReferenceModel
The ReferenceModel class contains methods related to reference models. A reference model is a reference of an external model.
Public classReferenceModelObject
The ReferenceModelObject class contains methods related to reference model objects. A reference model object is a subobject of a reference model.
Public classReinforcement
The Reinforcement class represents a reinforcement in the model. A reinforcement can either be a mesh, a single rebar, a rebar group or a strand.
Public classCode exampleSeam
The Seam class represents a seam. A seam is something that connects a main part to other parts along an edge.
Public classSelfIntersectingSurfaceException
This class represent an exception thrown when the an operation on a lofted plate has been determined to cause a self intersecting surface
Public classCode exampleSingleRebar
The SingleRebar class represents a single reinforcing bar.
Public classCode exampleSolid
The Solid class represents the physical object in the model created by a part instance. A solid instance can be used to query the actual geometry of the part and intersect that geometry with, for example, lines and planes.
Public classCode exampleSpiralBeam
A class for the spiral beam part.
Public classSpiralBeamDataException
The SpiralBeamDataException class represents an error that occurred during the spiral beam creation or modification.
Public classCode exampleStrandUnbondingData
The StrandUnbondingData class represents the unbonding of a rebar strand.
Public classCode exampleSurfaceObject
The SurfaceObject class represents a surface object in the model. Currently this class only support dynamic surfaces whose geometries are determined by the parts or pours they associate to. It is not allowed to modify the geometry of a dynamic surface on Open API. The polymesh setter of this class throws .
Public classCode exampleSurfaceTreatment
The SurfaceTreatment class defines a layer above a building element defining what a surface looks like. The surface could for example have a tiled look.
Public classCode exampleTask
The Task class defines a single building site task. It may contain parts, assemblies or other tasks. Tasks may have a hierarchy between them i.e. there are other tasks as subtasks for a parent task. Tasks may also depend on each other, have resources assigned to them or have a single worktype.
Public classTaskDependency
The TaskDependency class represents a dependency between two task objects. Each task may depend on many other tasks, but between two specific tasks only one type of a dependency may exist.

There are four types of dependencies:

  • FINISH_TO_FINISH (FF)
  • FINISH_TO_START (FS)
  • START_TO_FINISH (SF)
  • START_TO_START (SS)
Public classTaskWorktype
The TaskWorktype class defines a single worktype for a task object. Each task may belong to only one worktype.
Public classCode exampleTransformationPlane
The TransformationPlane class describes a transformation from global model coordinates to local and back to global.
Public classUndefinedCurveDirectionException
The UndefinedCurveDirectionException class represents an error when, cannot make inward/outward curve check.
Public classUnknownLoftedPlateErrorException
This class represent an exception thrown when an operation on a lofted plate caused an error of unknown origin
Public classUnsupportedChamferException
The UnsupportedChamferException class represents an error when, plates containing unsupported chamfer information.
Public classCode exampleWeld
The Weld class represents a normal weld in the model. A normal weld has a main part and a secondary part.
Public classWorkPlaneHandler
The WorkPlaneHandler class contains methods for getting and setting the current transformation plane.
Structures
Interfaces
  InterfaceDescription
Public interfaceIAssemblable
The IAssemblable interface dictates which model objects are capabable of belonging to an assembly at the leaf level.
Public interfaceIGeometryNode
The IGeometryNode interface represents geometry tree node. This is implemented by concrete classes for the various types of geometry nodes
Public interfaceIGeometryNodeVisitor
The IGeometryNodeVisitor interface is implemented by classes visiting geometry nodes
Delegates
  DelegateDescription
Public delegateEventsClashCheckDoneDelegate
The delegate to use for clash check completion.
Public delegateEventsClashDetectedDelegate
The delegate to use for clash detection. Encapsulates any method that takes a clash check data object as a parameter.
Public delegateEventsCommandStatusChangeDelegate
The delegate to use for command status change.
Public delegateEventsInterruptedDelegate
The delegate to use for interrupted event
Public delegateEventsModelChangedDelegate
The delegate to use for database commit.
Public delegateEventsModelLoadDelegate
The delegate to use for model load.
Public delegateEventsModelLoadInfoDelegate
The delegate to use for extended model load.
Public delegateEventsModelObjectChangedDelegate
The delegate to use for changed model objects. ModelObject inside ChangeData contains only identifier information. If properties need to be checked, Select() for object is required.
Public delegateEventsModelObjectNumberedDelegate
The delegate to use for model objects which are numbered. ModelObjects contain only identifier information. If properties need to be checked, Select() for object is required.
Public delegateEventsModelSaveAsDelegate
The delegate to use for model save as.
Public delegateEventsModelSaveDelegate
The delegate to use for model save.
Public delegateEventsModelSaveInfoDelegate
The delegate to use for model save with context information.
Public delegateEventsNumberingDelegate
The delegate to use for numbering.
Public delegateEventsProjectInfoChangedDelegate
The delegate to use for change in project info.
Public delegateEventsSelectionChangeDelegate
The delegate to use for selection change.
Public delegateEventsTeklaStructuresExitDelegate
The delegate to use for Tekla Structures exit.
Public delegateEventsViewCameraChangedDelegate
The delegate to use for view camera changed event
Enumerations
  EnumerationDescription
Public enumerationAssemblyAssemblyTypeEnum
The assembly types.
Public enumerationBasePointCoordinateSystemType
The type of the base points coordinate system.
Public enumerationBaseRebarGroupExcludeTypeEnum
The different ways to exclude reinforcing bars from the group.
Public enumerationBaseRebarGroupRebarGroupSpacingTypeEnum
The ways to distribute the reinforcing bars with different spacings.
Public enumerationBaseRebarModifierAffectedRebarEnum
This enum allows the caller to specify which end of the bar is of interest when calling the function GetAffectedBars.
Public enumerationBaseRebarModifierBarsAffectedEnum
The reinforcing bars affected.
Public enumerationBaseWeldWeldContourEnum
The weld contour.
Public enumerationBaseWeldWeldElectrodeClassificationEnum
The weld electrode classification.
Public enumerationBaseWeldWeldFinishEnum
The weld finish.
Public enumerationBaseWeldWeldIntermittentTypeEnum
Weld intermittent types.
Public enumerationBaseWeldWeldNDTInspectionEnum
The weld NDT inspection level.
Public enumerationBaseWeldWeldPlacementTypeEnum
Weld placement types.
Public enumerationBaseWeldWeldPreparationTypeEnum
Weld preparation types.
Public enumerationBaseWeldWeldProcessTypeEnum
The weld process type.
Public enumerationBaseWeldWeldTypeEnum
The weld types.
Public enumerationBeamBeamTypeEnum
The beam types. The strip and pad footings are valid only if the material type of the beam is concrete.
Public enumerationBentPlateBendShape
Enumerator to define different possibilities for bend shapes.
Public enumerationBentPlateGeometrySolverOperationStatus
Define possible statuses for geometry creation/modification commands.
Public enumerationBoltGroupBoltHoleTypeEnum
The special hole type.
Public enumerationBoltGroupBoltPlainHoleTypeEnum
The plain hole type.
Public enumerationBoltGroupBoltRotateSlotsEnum
The rotation of the slots (the holes).
Public enumerationBoltGroupBoltThreadInMaterialEnum
The thread in the material.
Public enumerationBoltGroupBoltTypeEnum
The type of the bolt.
Public enumerationBoltGroupErrorStatus
Define possible statuses for geometry creation/modification commands.
Public enumerationBooleanPartBooleanTypeEnum
Defines the boolean operation: an add or a cut.
Public enumerationChamferChamferTypeEnum
The basic shape type of the chamfer.
Public enumerationChangeDataChangeSourceTypeEnum
The source types of changed event.
Public enumerationChangeDataChangeTypeEnum
The types of changed event.
Public enumerationCircleRebarGroupCircleRebarGroupStirrupTypeEnum
The different stirrup types.
Public enumerationClashCheckDataClashTypeEnum
An enumeration for the different clash types.
Public enumerationContourPlateContourPlateTypeEnum
The contour plate types.
Public enumerationControlCircleControlCircleColorEnum
The different circle colors.
Public enumerationControlLineControlLineColorEnum
The different line colors.
Public enumerationControlObjectColorEnum
The different colors used for control objects (ControlLine and ControlCircle have their own).
Public enumerationControlObjectLineType
The line types (the presentation of the line).
Public enumerationEdgeChamferChamferEndTypeEnum
The end type of the edge chamfer.
Public enumerationHierarchicDefinitionTypeEnum
Defines the different types of classification hierarchies.
Public enumerationInputItemInputTypeEnum
Defines the type of the input.
Public enumerationLoadLoadAttachmentEnum
The load attachment.
Public enumerationLoadLoadPartNamesEnum
The load part names.
Public enumerationLoadLoadSpanningEnum
The load spanning.
Public enumerationLoadAreaAreaLoadFormEnum
The area load form.
Public enumerationLoadGroupColors
The possible display colors for loads in a load group.
Public enumerationLoadGroupLoadGroupDirection
The possible directions.
Public enumerationLoadGroupLoadGroupType
The possible types for load groups.
Public enumerationLoadLineLineLoadFormEnum
The line load form.
Public enumerationLoftedPlateLoftedPlateFaceTypeEnum
Lofted plate solid creation face types.
Public enumerationModelObjectModelObjectEnum
All possible concrete model object subclasses are defined here. This enumeration can be used to fetch certain types of objects from the Tekla Structures model.
Public enumerationModelObjectEnumeratorEnumeratorTypeEnum
The types of enumerator available.
Public enumerationPartCastUnitTypeEnum
The cast unit types.
Public enumerationPolyBeamPolyBeamTypeEnum
The polybeam types.
Public enumerationPolymeshPolymeshCheckerFlags
Polymesh check flags, please refer to PolymeshHealthCheckEnum for the corresponding result values.
Public enumerationPolymeshPolymeshHealthCheckEnum
Polymesh check error result codes. See the PolymeshCheckerFlags to see how to set the various checks.
Public enumerationPositionDepthEnum
The position in the depth sense.
Public enumerationPositionPlaneEnum
The position in the plane sense.
Public enumerationPositionRotationEnum
The position in the rotational sense.
Public enumerationRebarCrankingCrankedLengthTypeEnum
The cranked length type.
Public enumerationRebarCrankingCrankingTypeEnum
The cranking type.
Public enumerationRebarCrankingCrankSideEnum
The crank side.
Public enumerationRebarCrankingNullableEndCrankingTypeEnum
The end cranking type.
Public enumerationRebarEndDetailModifierEndTypeEnum
The end type.
Public enumerationRebarGroupRebarGroupStirrupTypeEnum
The different stirrup types.
Public enumerationRebarHookDataRebarHookShapeEnum
The different hook shapes.
Public enumerationRebarLappingLappingTypeEnum
The lapping type.
Public enumerationRebarLappingLapPlacementEnum
The placement of the lap relative to the associated RebarLegFace.
Public enumerationRebarLappingLapSideEnum
The side of the split that the lap is located.
Public enumerationRebarLegOriginEnum
Enumerator for different leg origins.
Public enumerationRebarLengthAdjustmentDataNullableLengthAdjustmentTypeEnum
The length adjustment type.
Public enumerationRebarMeshRebarMeshCrossBarLocationEnum
The ways to locate the crossing bars.
Public enumerationRebarMeshRebarMeshSpacingMethodEnum
The ways to distribute the reinforcing bars with different spacings.
Public enumerationRebarMeshRebarMeshTypeEnum
The different types of reinforcement meshes.
Public enumerationRebarPropertyModifierGroupingTypeEnum
The grouping type.
Public enumerationRebarSpacingExactSpacingValidation
Defines values used in validation of exact spacing elements.
Public enumerationRebarSpacingExcludeTypeEnum
The different ways to exclude reinforcing bars from the spacing.
Public enumerationRebarSpacingOffsetEnum
The offset distance type.
Public enumerationRebarSpacingSpacingType
Defines the different spacing types.
Public enumerationRebarSpacingZoneLengthEnum
The length type.
Public enumerationRebarSpacingZoneSpacingEnum
The spacing type.
Public enumerationRebarSpliceRebarSpliceBarPositionsEnum
The bar group positions in the splice.
Public enumerationRebarSpliceRebarSpliceTypeEnum
The splice types.
Public enumerationRebarSplitterSplitTypeEnum
The split type.
Public enumerationRebarSplitterStaggerTypeEnum
The side of the split that the additional offset (stagger) is located.
Public enumerationReferenceModelVisibilityEnum
The visibility type.
Public enumerationReinforcementRebarGeometryOptionEnum
Options for the function GetRebarGeometries.
Public enumerationReinforcementRebarGeometrySimplificationTypeEnum
The rebar geometry simplification type.
Public enumerationReinforcementRebarOffsetTypeEnum
The different types of offsets.
Public enumerationSolidSolidCreationTypeEnum
The creation type of the solid.
Public enumerationSpiralBeamErrorStatus
Define possible statuses for geometry creation/modification commands.
Public enumerationSurfaceTreatmentSurfaceColorEnum
The different surfacing colors.
Public enumerationSurfaceTreatmentSurfaceTypeEnum
The different surfacing types.
Public enumerationTaskDependencyDependencyTypeEnum
The task dependency types.
Public enumerationWeldWeldPositionEnum
The weld position.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next