BoltItem Class

The BoltItem class contains information about the bolts in the Tekla Structures bolt catalog.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsBoltItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class BoltItem

The BoltItem type exposes the following members.

Constructors
  NameDescription
Public methodBoltItem
Creates a new bolt item instance.
Top
Properties
  NameDescription
Public propertyLengths
The bolt item's length values.
Public propertySize
The bolt item's size.
Public propertyStandard
The bolt item's grade.
Public propertyType
The bolt item's type.
Top
Methods
  NameDescription
Public methodCode exampleExportBoltStandard
Exports the bolt item standard + needed bolt catalog items in *.bass-format to the to given file name. If path is not given bolt standard + items are exported to model folder. If filename is empty bolt standard name is used as filename.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next