DistanceListParse Method (String)

Parses a distance list from a string representation.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public static DistanceList Parse(
	string input
)

Parameters

input
Type: SystemString
The input string.

Return Value

Type: DistanceList
The distance list.
Examples
This example shows how to parse distance lists with the current culture information and the current unit type.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // Current unit type controls the default unit type used in parsing.
           // The default unit is millimeter.
           Distance.CurrentUnitType = Distance.UnitType.Millimeter;

           // By default, the parsing uses the current unit type and the current culture info.
           // This will be parsed as 3 millimeters and 2 millimeters.
           DistanceList defaultFormat = DistanceList.Parse("3 2");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next