RebarSplitter Class

The RebarSplitter class represents a modifier that can split the RebarSet reinforcing bars that pass through it.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarSplitter : BaseRebarModifier

The RebarSplitter type exposes the following members.

Constructors
  NameDescription
Public methodRebarSplitter
Initializes a new instance of the RebarSplitter class.
Top
Properties
  NameDescription
Public propertyBarsAffected
Gets or sets the reinforcing bars affected.
(Inherited from BaseRebarModifier.)
Public propertyCranking
Gets or sets the rebar cranking.
Public propertyCurve
Gets or sets the geometric Contour of the rebar modifier.
(Inherited from BaseRebarModifier.)
Public propertyFather
Gets or sets the RebarSet to which the modifier belongs. Only reinforcing bars generated by this RebarSet can be modified by this rebar modifier.
(Inherited from BaseRebarModifier.)
Public propertyFirstAffectedBar
Gets or sets the first affected bar. If set to zero, the first affected bar will be chosen automatically.
(Inherited from BaseRebarModifier.)
Public propertyFollowEdges
Gets or sets a flag that indicates whether the modifier should attempt to follow the leg face edges located between its end points.
(Inherited from BaseRebarModifier.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLapping
Gets or sets the rebar lapping.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertySplitOffset
Gets or sets the offset of the split from the location of the rebar splitter.
Public propertySplitType
Gets or sets the split type.
Public propertyStaggerOffset
Gets or sets the additional offset (stagger) of the split location for every other split reinforcing bar.
Public propertyStaggerType
Gets or sets the stagger type.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the rebar modifier from the model database.
(Inherited from BaseRebarModifier.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodGetAffectedBars
Gets the virtual bars affected by this splitter.
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the rebar modifier into the model database.
(Inherited from BaseRebarModifier.)
Public methodModify
Modifies the existing rebar modifier in the model database to match the current one.
(Inherited from BaseRebarModifier.)
Public methodSelect
Selects the rebar modifier from the model database. The identifier must be set.
(Inherited from BaseRebarModifier.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
The following example shows how to create and add a RebarSplitter, to a rebarset.
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
            // Create and insert a rebarset (see the RebarSet example).
            var rebarSet = new RebarSet();

            // Create the RebarSplitter
            var strip = new RebarSplitter();
            strip.Father = rebarSet;
            strip.SplitType = RebarSplitter.SplitTypeEnum.LAPPING;
            strip.Lapping.LappingType = RebarLapping.LappingTypeEnum.CUSTOM_LAPPING;
            strip.Lapping.LapLength = 100;
            strip.StaggerType = RebarSplitter.StaggerTypeEnum.STAGGER_LEFT;
            strip.StaggerOffset = 200;
            strip.SplitOffset = 50;
            strip.Curve.AddContourPoint(new ContourPoint(new Point(400, 200, 0), null));
            strip.Curve.AddContourPoint(new ContourPoint(new Point(400, 1000, 0), null));
            strip.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next