RebarSplitter Class

The RebarSplitter class represents a modifier that can split the RebarSet reinforcing bars that pass through it.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarSplitter : BaseRebarModifier

The RebarSplitter type exposes the following members.

Constructors
  NameDescription
Public methodRebarSplitter
Initializes a new instance of the RebarSplitter class.
Top
Properties
  NameDescription
Public propertyCranking
Gets or sets the rebar cranking.
Public propertyLapping
Gets or sets the rebar lapping.
Public propertySplitOffset
Gets or sets the offset of the split from the location of the rebar splitter.
Public propertySplitType
Gets or sets the split type.
Public propertyStaggerOffset
Gets or sets the additional offset (stagger) of the split location for every other split reinforcing bar.
Public propertyStaggerType
Gets or sets the stagger type.
Top
Methods
  NameDescription
Public methodGetAffectedBars
Gets the virtual bars affected by this splitter.
Top
Examples
The following example shows how to create and add a RebarSplitter, to a rebarset.
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
            // Create and insert a rebarset (see the RebarSet example).
            var rebarSet = new RebarSet();

            // Create the RebarSplitter
            var strip = new RebarSplitter();
            strip.Father = rebarSet;
            strip.SplitType = RebarSplitter.SplitTypeEnum.LAPPING;
            strip.Lapping.LappingType = RebarLapping.LappingTypeEnum.CUSTOM_LAPPING;
            strip.Lapping.LapLength = 100;
            strip.StaggerType = RebarSplitter.StaggerTypeEnum.STAGGER_LEFT;
            strip.StaggerOffset = 200;
            strip.SplitOffset = 50;
            strip.Curve.AddContourPoint(new ContourPoint(new Point(400, 200, 0), null));
            strip.Curve.AddContourPoint(new ContourPoint(new Point(400, 1000, 0), null));
            strip.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next