ProjectInfo Class

The ProjectInfo class provides project information about the currently open Tekla Structures model.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelProjectInfo

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ProjectInfo

The ProjectInfo type exposes the following members.

Properties
  NameDescription
Public propertyAddress
The address information of the ProjectInfo.
Public propertyBuilder
The builder information of the ProjectInfo.
Public propertyCountry
The address country information of the ProjectInfo.
Public propertyDescription
The description of the ProjectInfo.
Public propertyDesigner
The designer information of the ProjectInfo.
Public propertyEndDate
The end date information of the ProjectInfo.
Public propertyGUID
The GUID field of the ProjectInfo.
Public propertyInfo1
The Info 1 field of the ProjectInfo.
Public propertyInfo2
The Info 2 field of the ProjectInfo.
Public propertyLocation
The address location information of the ProjectInfo.
Public propertyModelSharingLocalPath Obsolete.
The local folder for model sharing. Is null if not defined for the model.
Public propertyModelSharingServerPath Obsolete.
The server path for model sharing. Is null if not defined for the model.
Public propertyName
The name information of the ProjectInfo.
Public propertyObject
The object information of the ProjectInfo.
Public propertyPostalBox
The address postal box information of the ProjectInfo.
Public propertyPostalCode
The address postal code information of the ProjectInfo.
Public propertyProjectNumber
The project number information of the ProjectInfo.
Public propertyRegion
The address region information of the ProjectInfo.
Public propertyStartDate
The start date information of the ProjectInfo.
Public propertyTown
The address town information of the ProjectInfo.
Top
Methods
  NameDescription
Public methodStatic memberGetBasePointByGuid
Gets a base point by given guid.
Public methodStatic memberGetBasePointByName
Gets a base point by given name.
Public methodStatic memberGetBasePoints
Gets all available base points as a list.
Public methodStatic memberGetCurrentCoordsysBasePoint
Gets the current base point, if set.
Public methodGetDoubleUserProperties
Retrieves all double properties for the ProjectInfo.
Public methodGetDynamicStringProperty
Gets a dynamic string property for the ProjectInfo.
Public methodGetIntegerUserProperties
Retrieves all integer properties for the ProjectInfo.
Public methodStatic memberGetProjectBasePoint
Gets the project base point, if any set.
Public methodGetStringUserProperties
Retrieves all string properties for the ProjectInfo.
Public methodGetUserProperty(String, Double)
Retrieves a double property for the ProjectInfo.
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the ProjectInfo.
Public methodGetUserProperty(String, String)
Retrieves a string property for the ProjectInfo.
Public methodModify
Modifies the current project information.
Public methodStatic memberSetCurrentCoordsysToBasePoint
Sets the current base point.
Public methodSetDynamicStringProperty
Sets a dynamic string property for the ProjectInfo.
Public methodSetUserProperty(String, Double)
Sets a double property for the ProjectInfo.
Public methodSetUserProperty(String, Int32)
Sets an integer property for the ProjectInfo.
Public methodSetUserProperty(String, String)
Sets a string property for the ProjectInfo.
Top
Examples
The following example gets the project information and shows the value of the Name property in a message dialog:
using Tekla.Structures.Model;
using System.Windows.Forms;

public class Example
{
    public void Example1()
    {
        Model CurrentModel = new Model();
        ProjectInfo ProjectInfo = CurrentModel.GetProjectInfo();

        if (CurrentModel.GetConnectionStatus())
        {
            if (ProjectInfo.Name.Length > 0)
            {
                MessageBox.Show(ProjectInfo.Name);
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next