AnalysisDesignParameterMulti Class

The AnalysisDesignParameterMulti class contains information related to analysis design parameters with multi values.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisDesignParameterMulti : AnalysisDesignParameterBase

The AnalysisDesignParameterMulti type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisDesignParameterMulti(Int32)
Initializes a new instance of the AnalysisDesignParameterMulti class.
Public methodAnalysisDesignParameterMulti(String, Int32, Identifier)
Initializes a new instance of the AnalysisDesignParameterMulti class.
Top
Properties
  NameDescription
Public propertyMultiValueCount
Gets the multi value count of the analysis design parameter.
Top
Methods
  NameDescription
Public methodGetValue
Gets the value specified by the index of the analysis design parameter.
Public methodModify
Modifies an analysis design parameter. The ID has to be set.
(Overrides AnalysisDesignParameterBaseModify.)
Public methodSelect
Selects an analysis design parameter.
(Overrides AnalysisObjectSelect.)
Public methodSetValue
Sets the value specified by the index of the analysis design parameter.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next