AnalysisDesignParameterMulti Class

The AnalysisDesignParameterMulti class contains information related to analysis design parameters with multi values.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisDesignParameterMulti : AnalysisDesignParameterBase

The AnalysisDesignParameterMulti type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisDesignParameterMulti(Int32)
Initializes a new instance of the AnalysisDesignParameterMulti class.
Public methodAnalysisDesignParameterMulti(String, Int32, Identifier)
Initializes a new instance of the AnalysisDesignParameterMulti class.
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyIsGeneral
Gets or sets a value indicating whether the design parameter is general.
(Inherited from AnalysisDesignParameterBase.)
Public propertyMultiValueCount
Gets the multi value count of the analysis design parameter.
Public propertyName
Gets or sets the name of the analysis design parameter.
(Inherited from AnalysisDesignParameterBase.)
Public propertyUnit
Gets or sets the unit of the analysis design parameter.
(Inherited from AnalysisDesignParameterBase.)
Top
Methods
  NameDescription
Public methodGetValue
Gets the value specified by the index of the analysis design parameter.
Public methodModify
Modifies an analysis design parameter. The ID has to be set.
(Overrides AnalysisDesignParameterBaseModify.)
Public methodSelect
Selects an analysis design parameter.
(Overrides AnalysisObjectSelect.)
Public methodSetValue
Sets the value specified by the index of the analysis design parameter.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next