DrawingHatchColors Enumeration

The hatch colors used in Tekla.Structures.Drawing.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public enum DrawingHatchColors
Members
  Member nameValueDescription
Invisible152 The light gray color: the "invisible color". Light gray is visible only on the screen and not in printed or exported drawings.
Black153 The black color.
NewLine1154 The brown color.
NewLine2155 The green color.
NewLine3156 The dark blue color.
NewLine4157 The forest green color.
NewLine5158 The orange color.
NewLine6159 The gray color.
Red160 The red color.
Green161 The bright green color.
Blue162 The blue color.
Cyan163 The turquoise color.
Yellow164 The yellow color.
Magenta165 The magenta color.
Special120 The special color. Defined with advanced options XS_HATCH_SPECIAL_COLOR_R, XS_HATCH_SPECIAL_COLOR_G and XS_HATCH_SPECIAL_COLOR_B
Gray30130 The Gray30 rgb(0.3, 0.3, 0.3) color.
Gray50131 The Gray50 rgb(0.5, 0.5, 0.5) color.
Gray70132 The Gray70 rgb(0.7, 0.7, 0.7) color.
Gray90133 The Gray90 rgb(0.9, 0.9, 0.9) color.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next