ModelHistoryGetDeletedObjectsWithType Method

Note: This API is now obsolete.

Gets based on type a list of the objects that have been deleted after the modification stamp.

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[ObsoleteAttribute("Use TakeModifications() instead.")]
public static ModelObjectEnumerator GetDeletedObjectsWithType(
	ModificationStamp ModStamp,
	ModelObjectModelObjectEnum Enum
)

Parameters

ModStamp
Type: Tekla.Structures.Model.HistoryModificationStamp
The modification stamp.
Enum
Type: Tekla.Structures.ModelModelObjectModelObjectEnum
The type of the objects to return.

Return Value

Type: ModelObjectEnumerator
A list of the objects that have been deleted after the given modification stamp.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next