AnalysisObjectAnalysisObjectEnum Enumeration

All subclasses of analysis objects are defined here. This enumeration can be used to select certain types of analysis objects.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public enum AnalysisObjectEnum
Members
  Member nameValueDescription
ANALYSIS_NOT_DEFINED0 The analysis object type is not defined.
ANALYSIS_MODEL1 This type is for selecting analysis models from the current Tekla Structures model.
ANALYSIS_PART2 This type is for selecting analysis parts from the current analysis model.
ANALYSIS_BAR3 This type is for selecting analysis bars from the current analysis model.
ANALYSIS_AREA4 This type is for selecting analysis areas from the current analysis model.
ANALYSIS_VOLUME5 This type is for selecting analysis volumes from the current analysis model.
ANALYSIS_MEMBER6 This type is for selecting analysis members from the current analysis model.
ANALYSIS_DECOMPOSED_LOAD_NODE7 This type is for selecting decomposed node loads from the current analysis model.
ANALYSIS_DECOMPOSED_LOAD_BAR8 This type is for selecting decomposed bar loads from the current analysis model.
ANALYSIS_DECOMPOSED_LOAD_AREA9 This type is for selecting decomposed area loads from the current analysis model.
ANALYSIS_DECOMPOSED_LOAD_MEMBER10 This type is for selecting decomposed member loads from the current analysis model.
ANALYSIS_DECOMPOSED_LOAD_SELFWEIGHT11 This type is for selecting decomposed selfweight loads from the current analysis model.
ANALYSIS_DECOMPOSED_LOAD_TEMPERATURE12 This type is for selecting decomposed temperature loads from the current analysis model.
ANALYSIS_AREA_POLYGON13 This type is for selecting area polygons from the current analysis model.
ANALYSIS_AREA_HOLE14 This type is for selecting area holes from the current analysis model.
ANALYSIS_EDGE15 This type is for selecting area edges from the current analysis model.
ANALYSIS_EDGE_HOLE16 This type is for selecting area hole edges from the current analysis model.
ANALYSIS_POSITION_BAR17 This type is for selecting bar positions from the current analysis model.
ANALYSIS_POSITION_AREA18 This type is for selecting area polygon positions from the current analysis model.
ANALYSIS_POSITION_AREA_INNER19 This type is for selecting area inner positions from the current analysis model.
ANALYSIS_POSITION_AREA_HOLE20 This type is for selecting area hole positions from the current analysis model.
ANALYSIS_POSITION_EDGE_SPLIT21 This type is for selecting edge split positions from the current analysis model.
ANALYSIS_POSITION_EDGE_SPLIT_HOLE22 This type is for selecting edge split hole positions from the current analysis model.
ANALYSIS_POSITION_FACE23 This type is for selecting face positions from the current analysis model.
ANALYSIS_NODE24 This type is for selecting analysis nodes from the current analysis model.
ANALYSIS_NODE_LINK25 This type is for selecting analysis node links from the current analysis model.
ANALYSIS_DESIGN_PARAMETER26 This type is for selecting analysis design parameters from the current analysis model.
ANALYSIS_DESIGN_PARAMETER_MULTI27 This type is for selecting analysis design multi parameters from the current analysis model.
ANALYSIS_MODEL_CONNECTIVITY_RULE28 This type is for selecting analysis connectivity rules from the current analysis model.
ANALYSIS_FACE29 This type is for selecting analysis faces from the current analysis model.
ANALYSIS_VOLUME_ITEM30 This type is for selecting analysis volume items from the current analysis model.
ANALYSIS_CROSS_SECTION31 This type is for selecting analysis cross sections from the current analysis model.
ANALYSIS_SUB_SECTION32 This type is for selecting analysis subsections from the current analysis model.
ANALYSIS_MATERIAL33 This type is for selecting analysis materials from the current analysis model.
ANALYSIS_CROSS_SECTION_GROUP34 This type is for selecting analysis cross section groups from the current analysis model.
ANALYSIS_RIGID_DIAPHRAGM35 This type is for selecting analysis rigid diaphragms from the current analysis model.
ANALYSIS_LOAD_GROUP36 This type is for selecting analysis load groups from the current analysis model.
ANALYSIS_LOAD_COMBINATION37 This type is for selecting analysis load combinations from the current analysis model.
ANALYSIS_MODEL_LOAD38 This type is for selecting model loads from the current analysis model.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next