PickerInputObjectAndAPoint Class

The PickerInputObjectAndAPoint class represents a pick of an object in a view. It provides both the picked object and the point used to pick the object. Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView, out Point PickedPoint).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public class PickerInputObjectAndAPoint : PickerInputObject

The PickerInputObjectAndAPoint type exposes the following members.

Constructors
  NameDescription
Public methodPickerInputObjectAndAPoint
Creates a new PickerInputObjectAndAPoint instance representing the pick of a drawing object and the coordinates of the point used to pick the object.
Top
Properties
  NameDescription
Public propertyPickedPoint
Gets or sets the picked point in the view coordinates.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PickerInputObjectIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next