GridLineGridLabel Class

The GridLabel class contains the grid labels of the grid lines, the text label and the insertion points.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGridLineGridLabel

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridLabel : IAxisAlignedBoundingBox, 
	IMovableRelative

The GridLineGridLabel type exposes the following members.

Constructors
  NameDescription
Public methodGridLineGridLabel
Creates a new default grid label instance.
Top
Properties
  NameDescription
Public propertyCenterPoint
The center point of the grid label.
Public propertyFrameHeight
The height of the grid label frame.
Public propertyFrameWidth
The width of the grid label frame.
Public propertyGridLabelPoint
The grid line's label point. If the value of GridLabelPoint differs from the OffsetGridPoint value, a leader line will be created to the GridLabelPoint position. You can remove the leader line by setting GridLabelPoint to the GridPoint value (or by setting the GridLabelPoint anywhere on the grid line, but then the offset will change).
Public propertyGridLabelText
The grid line's label text.
Public propertyGridPoint
The grid line point, without offsets taken into consideration (model grid line coordinates).
Public propertyOffsetGridPoint
The grid line point where the grid line actually ends, with offsets applied.
Public propertyTextHeight
The height of the grid label's text frame.
Public propertyTextWidth
The width of the grid label's text frame.
Top
Methods
  NameDescription
Public methodGetAxisAlignedBoundingBox
The bounding box of the grid line label (rectangle format, axis aligned).
Public methodGetAxisAlignedBoundingBoxOfTextLabel
The bounding box of the grid line label's text (rectangle format, axis aligned).
Public methodMoveObjectRelative
Moves the object using the move vector.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next