Symbol Class

The Symbol class defines a drawing object that is displayed as a symbol in a drawing. Symbols are located in the environment directory under the folder named "symbols" in .sym files that can contain up to 255 symbols. Symbol files can be created with SymEd. See the Tekla Structures help for more information.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Symbol : DrawingObject, 
	IAxisAlignedBoundingBox, IObjectAlignedBoundingBox, IMovableRelative, IPlacing, IHasChildren, 
	IHideable

The Symbol type exposes the following members.

Constructors
  NameDescription
Public methodSymbol(ViewBase, Point)
Creates a new symbol instance using the default symbol information and standard attributes.
Public methodSymbol(ViewBase, Point, PlacingBase)
Creates a new symbol instance using the default symbol information, standard attributes and the given placing.
Public methodSymbol(ViewBase, Point, SymbolInfo)
Creates a new symbol instance using standard attributes.
Public methodSymbol(ViewBase, Point, SymbolInfo, PlacingBase)
Creates a new symbol instance using standard attributes.
Public methodSymbol(ViewBase, Point, SymbolInfo, SymbolSymbolAttributes)
Creates a new symbol instance using the given attributes.
Public methodSymbol(ViewBase, Point, SymbolInfo, SymbolSymbolAttributes, PlacingBase)
Creates a new symbol instance using the given attributes and placing.
Top
Properties
  NameDescription
Public propertyAttributes
Gets or sets the symbol attributes.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyInsertionPoint
Gets or sets the symbol insertion point.
Public propertyPlacing
The current placing of the object. See the placing types for different placing options.
Public propertySymbolInfo
Gets or sets the symbol information.
Top
Methods
  NameDescription
Public methodDelete
Deletes the symbol from the current drawing database.
(Overrides DatabaseObjectDelete.)
Public methodGetAxisAlignedBoundingBox
Returns the bounding box of the symbol (rectangle format).
Public methodGetObjectAlignedBoundingBox
Returns the bounding box of the symbol (rectangle format).
Public methodGetObjects
Gets the children objects of the current object.
Public methodGetObjects(Type)
Gets the children objects of the current object that are of certain types.
Public methodInsert
Inserts the symbol into the current drawing database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the symbol in the current drawing database.
(Overrides DatabaseObjectModify.)
Public methodMoveObjectRelative
Moves the object using the move vector.
Public methodSelect
Selects the symbol from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
Examples
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase;

           Symbol xs = new Symbol(view, new Point(1000, 2000), new SymbolInfo("xsteel", 52));
           xs.Attributes.Angle = 30;
           xs.Attributes.Frame.Type = FrameTypes.Rectangular;
           xs.Attributes.Height = 4.0;
           xs.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next