RebarLegFace Class

Defines a rebar leg face that is used in a RebarSet. Rebar leg faces control how the RebarSet generates the reinforcing bars.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarLegFace

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarLegFace

The RebarLegFace type exposes the following members.

Constructors
  NameDescription
Public methodRebarLegFace
Initializes a new instance of the RebarLegFace class.
Public methodRebarLegFace(Contour)
Initializes a new instance of the RebarLegFace class using the specified Contour.
Top
Properties
  NameDescription
Public propertyAdditonalOffset
Gets or sets the user defined offset of the rebars from the rebar leg face.
Public propertyContour
Gets or sets the outer Contour of the rebar leg face.
Public propertyId
Gets or sets an identifier that may be used to identify instances of the same rebar leg face.
Public propertyLayerOrderNumber
Gets or sets the layer order number of the rebar leg face.
Public propertyReversed
Gets or sets a value indicating whether the cover thickness is opposite to the coordinate system Z direction for the rebar leg face.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next