Tekla.Structures.Model.UI Namespace

The Tekla.Structures.Model.UI namespace consists of some classes that can be used, for example, to highlight objects from the user interface.
Classes
  ClassDescription
Public classCode exampleClipPlane
The ClipPlane class defines a clip plane which can be used together with a visible view.
Public classClipPlaneCollection
The ClipPlaneCollection class handles the collection of the clip planes.
Public classCode exampleColor
The Color class represents an RGB color with transparency. The color values must be between 0.0 and 1.0.
Public classGraphicPolyLine
Public classCode exampleGraphicsDrawer
The GraphicsDrawer class draws temporary graphics in the currently active rendered view in Tekla Structures.
Public classCode exampleMesh
The Mesh class represents a mesh for drawing three-dimensional data.
Public classCode exampleModelObjectSelector
The ModelObjectSelector class can be used to select objects from the Tekla Structures user interface. Currently, these selections both select the objects from the database and highlight them visually.
Public classCode exampleModelObjectVisualization
The class to set and clear temporary visualization (color and transparency) for model objects in view. Permananet representation will be restored when view is redrawed or temporary visualization is cleared. Can be used also to fetch current permanent representation of model object.
Public classModelViewEnumerator
The ModelViewEnumerator class is an enumerator class for model views. The enumerator enables model view items to be looped.
Public classCode examplePicker
The Picker class can be used to query the user to do manual picks of objects and points from the Tekla Structures model. The methods throw an exception if the user interrupts (cancels) the pick command.
Public classCode examplePickInput
The PickInput class handles the input of picked objects and positions.
Public classCode exampleView
The View class contains methods related to views.
Public classCode exampleViewCamera
The ViewCamera class defines a camera which can be used together with a visible view. Always supply a properly orthogonalized camera up vector when rotating the camera.
Public classCode exampleViewHandler
The ViewHandler class contains methods for handling views.
Public classViewVisibilitySettings
The View visibility settings class contains object visibility information related to view.
Enumerations
  EnumerationDescription
Public enumerationGraphicPolyLineLineType
The appearance of the line. For instance solid, dashed or dotted.
Public enumerationPickerPickObjectEnum
The possible model object pick types for a single object.
Public enumerationPickerPickObjectsEnum
The possible model object pick types for many objects.
Public enumerationPickerPickPointEnum
The possible point pick types.
Public enumerationTemporaryTransparency
The possible temporary transparencies. Used to temporarily change transparency of a model object to visualize some state in the model.
Public enumerationViewDisplayOrientationType
The view plane types. The plane type can be changed.
Public enumerationViewViewProjectionType
The view projection types. The projection type can be read but not changed.
Public enumerationViewViewRenderingType
The view rendering types. Only rendered views can be modified.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next