AnalysisEdge Class

The AnalysisEdge class contains information related to analysis edges.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisEdge : AnalysisObject

The AnalysisEdge type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisEdge
Creates a new instance of the AnalysisEdge class.
Top
Properties
  NameDescription
Public propertyConnectivity
The connectivity of the analysis edge.
Public propertyRadius
The radius of the analysis edge.
Public propertySplitPositions
The split positions of the analysis edge.
Top
Methods
  NameDescription
Public methodAddSplit
Adds a split position to the analysis edge.
Public methodCopyData
Copies data from another analysis edge.
Public methodGetSplitPositions
Gets the split positions of the analysis edge.
Public methodModify
Modifies an analysis edge. The AnalysisModelName has to be set.
Public methodSelect
Selects an analysis edge.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next