AnalysisNodeLink Class

The AnalysisNodeLink class contains information related to analysis node links.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisNodeLink : AnalysisObject

The AnalysisNodeLink type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisNodeLink
Initializes a new instance of the AnalysisNodeLink class.
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyCoordinateSystem
The coordinate system of the analysis node link.
Public propertyDisabled
Indicates whether the analysis node link is disabled.
Public propertyEndConnectivity
The end connectivity of the analysis node link.
Public propertyEndNode
The end node.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyIsUserConnectivity
Indicates whether the analysis node has a user defined connectivity.
Public propertyIsUserNodeLink
Indicates whether the analysis node is a user node link.
Public propertyOwnerPartIDs
The list of the identifiers of the owner parts.
Public propertyStartConnectivity
The start connectivity of the analysis node link.
Public propertyStartNode
The start node.
Top
Methods
  NameDescription
Public methodDelete
Deletes a user analysis node link. The ID has to be set.
Public methodInsert
Inserts a user analysis node link. The AnalysisModelName has to be set. The StartNodeID has to be set. The EndNodeID has to be set.
Public methodModify
Modifies an analysis node link. The ID has to be set.
Public methodSelect
Selects an analysis node link. The ID has to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next