Operation Class

The Operation class implements Tekla Structures level operations.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.OperationsOperation

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public static class Operation

The Operation type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCode exampleAddToPourUnit
Adds model objects as part of a pour unit Model object types accepted are assembly types except cast in situ, reinforcements of different kind, components and bolts
Public methodStatic memberCalculatePourUnits
Calculate and assign objects to pour unit Model object types that are associated with pour unit are assembly types except cast in situ, reinforcements of different kind, components and screws
Public methodStatic memberCombine(Beam, Beam)
Combines two beams into one beam.
Public methodStatic memberCombine(RebarGroup, RebarGroup)
Combines two rebar groups into one rebar group.
Public methodStatic memberCombine(SingleRebar, SingleRebar)
Combines two single rebars into one rebar.
Public methodStatic memberConvertPartToItem
Public methodStatic memberCode exampleCopyObject(ModelObject, Vector)
Copies the model object using the given translation vector.
Public methodStatic memberCode exampleCopyObject(ModelObject, CoordinateSystem, CoordinateSystem)
Copies the model object between the given translation coordinate systems.
Public methodStatic memberCreateBentPlateByFaces(Part, IListPoint, Part, IListPoint)
Public methodStatic memberCreateBentPlateByFaces(Part, Face, Part, Face)
Modifies the first plate by adding a cylindrical bend that connects it to the second plate creating a new BentPlate instance based on two parts and selected faces in each part. See CreateBentPlateByFaces(Part, Face, Part, Face, BentPlateBendShape).
Public methodStatic memberCreateBentPlateByFaces(Part, IListPoint, Part, IListPoint, Double)
Modifies the first plate by adding a bend that connects it to the second plate creating a new BentPlate instance based on two parts, selected faces in each part and radius. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, LineSegment, ConnectiveGeometry, LineSegment, Double).
Public methodStatic memberCreateBentPlateByFaces(Part, IListPoint, Part, IListPoint, BentPlateBendShape)
Modifies the first plate by adding a bend that connects it to the second plate creating a new BentPlate instance based on two parts and selected faces in each part. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, LineSegment, ConnectiveGeometry, LineSegment, BentPlateBendShape).
Public methodStatic memberCreateBentPlateByFaces(Part, Face, Part, Face, Double)
Modifies the first plate by adding a bend that connects it to the second plate creating a new BentPlate instance based on two parts and selected faces in each part and radius. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, LineSegment, ConnectiveGeometry, LineSegment, Double).
Public methodStatic memberCreateBentPlateByFaces(Part, Face, Part, Face, BentPlateBendShape)
Modifies the first plate by adding a bend that connects it to the second plate creating a new BentPlate instance based on two parts and selected faces in each part. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, LineSegment, ConnectiveGeometry, LineSegment, BentPlateBendShape).
Public methodStatic memberCreateBentPlateByParts(Part, Part)
Modifies the first plate by adding a cylindrical bend that connects it to the second plate creating a new BentPlate instance based on two parts. See CreateBentPlateByParts(Part, Part, BentPlateBendShape).
Public methodStatic memberCreateBentPlateByParts(Part, Part, Double)
Modifies the first plate by adding a bend that connects it to the second plate creating a new BentPlate instance based on two parts and a radius. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, ConnectiveGeometry, Double).
Public methodStatic memberCreateBentPlateByParts(Part, Part, BentPlateBendShape)
Modifies the first plate by adding a bend that connects it to the second plate creating a new BentPlate instance based on two parts. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, ConnectiveGeometry, BentPlateBendShape).
Public methodStatic memberCreateConicalBentPlateByFaces(Part, IListPoint, Part, IListPoint, Double, Double)
Modifies the first plate by adding a conical bend that connects it to the second plate creating a new BentPlate instance based on two parts, selected faces in each part and radius. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, LineSegment, ConnectiveGeometry, LineSegment, Double).
Public methodStatic memberCreateConicalBentPlateByFaces(Part, Face, Part, Face, Double, Double)
Modifies the first plate by adding a conical bend that connects it to the second plate creating a new BentPlate instance based on two parts and selected faces in each part, and the largest radius of the conical section and the cone aperture. This method can change GUID when using from plug-ins. To keep GUID, use AddLeg(ConnectiveGeometry, LineSegment, ConnectiveGeometry, LineSegment, Double).
Public methodStatic memberCreateConicalBentPlateByPartsAndAperture
Modifies the first plate by adding a conical bend that connects it to the second plate creating a new BentPlate instance based on two parts. The resulting bend will have the given aperture and the provided larger radius.
Public methodStatic memberCreateConicalBentPlateByPartsAndTwoRadiuses
Modifies the first plate by adding a conical bend that connects it to the second plate creating a new BentPlate instance based on two parts. The resulting bend will have the two given radiuses.
Public methodStatic memberCreateDGNv8Export
Dgn export from all or selected objects.
Public methodStatic memberCode exampleCreateIFC4ExportFromAll
Creates IFC4 export from all objects using the given file name.

See Tekla Structures Help for more information about IFC4 export files.

Public methodStatic memberCode exampleCreateIFC4ExportFromSelected
Creates IFC4 export from the selected parts using the given file name.

See Tekla Structures Help for more information about IFC4 export files.

Public methodStatic memberCode exampleCreateMISFileFromAll
Creates MIS files from all parts using the given file name.

See Tekla Structures Help for more information about MIS files.

Public methodStatic memberCode exampleCreateMISFileFromSelected
Creates MIS files from the selected parts using the given file name.

See Tekla Structures Help for more information about MIS files.

Public methodStatic memberCode exampleCreateNCFilesByPartId
Creates NC files from the selected parts using the given NC template name.

See Tekla Structures Help for more information about NC files.

Public methodStatic memberCode exampleCreateNCFilesFromAll(String, String)
Creates NC files from all parts using the given NC template name.

See Tekla Structures Help for more information about NC files.

Public methodStatic memberCode exampleCreateNCFilesFromAll(String, String, Boolean, String, Boolean, String)
Creates NC files from all parts using the given NC template name.

See Tekla Structures Help for more information about NC files.

Public methodStatic memberCode exampleCreateNCFilesFromSelected(String, String)
Creates NC files from the selected parts using the given NC template name.

See Tekla Structures Help for more information about NC files.

Public methodStatic memberCode exampleCreateNCFilesFromSelected(String, String, Boolean, String, Boolean, String)
Creates NC files from the selected parts using the given NC template name.

See Tekla Structures Help for more information about NC files.

Public methodStatic memberCode exampleCreateReportFromAll
Creates a report from all the objects using the given template name and filename.

If a path is not given in the filename, the file is created to the folder defined with the advanced option XS_REPORT_OUTPUT_DIRECTORY.

If the given folder does not exist, the report creation fails.

Internally, this method is asynchronous, and because of that the output file cannot be immediately available.

See Tekla Structures Help for more information about reports.

Public methodStatic memberCode exampleCreateReportFromSelected
Creates a report from the selected objects using the given template name and filename.

If a path is not given in the filename, the file is created to the folder defined with the advanced option XS_REPORT_OUTPUT_DIRECTORY.

If the given folder does not exist, the report creation fails.

See Tekla Structures Help for more information about reports.

Public methodStatic memberDisplayPrompt
Displays a message in the status bar.
Public methodStatic memberDisplayReport
Opens and displays a report with the given name.

If a path is not given in the filename, the file is searched from the folder defined with the advanced option XS_REPORT_OUTPUT_DIRECTORY.

See Tekla Structures Help for more information about reports.

Public methodStatic memberExplodeBentPlate
Deletes bentPlate and inserts ContourPlates instances equivalent to the ones used to create bentPlate. The ContourPlate created from the main polygon has the same identifier as bentPlate.
Public methodStatic memberGetHandlePoints
Get the Shape Item Handle Points
Public methodStatic memberGetSimilarNumberedObjects
Gets similar objects based on numbering of given object.
Public methodStatic memberGroup
Groups a list of single rebars or rebar groups and creates a new rebar group.
Public methodStatic memberHighlight
Highlight the list of objects from the user interface. Only the list of objects will be highlighted, the rest will be unhighlighted. But it will keep the status of the selected objects. To unhighlight give an empty list as a parameter.
Public methodStatic memberIsMacroRunning
Returns true if a macro is running, false otherwise.

Macros are saved as *.cs files in the folder defined with the XS_MACRO_DIRECTORY variable.

See Tekla Structures Help for more information about macros.

Public methodStatic memberIsModelAutoSaved Obsolete.
Tells whether a model has auto saved information.
Public methodStatic memberIsNumberingAllowed
Checks whether the numbering is allowed or not in the current configuration.
Public methodStatic memberIsNumberingUpToDate
Checks whether the numbering is up-to-date for an assembly, part, rebar, surface treatment, pour object or break.
Public methodStatic memberIsNumberingUpToDateAll
Checks whether the numbering is up-to-date for every assembly, part and rebar on the model.
Remarks
Using this method is much faster than checking each object individually.
Public methodStatic memberCode exampleMoveObject(ModelObject, Vector)
Moves the model object using the given translation vector.
Public methodStatic memberCode exampleMoveObject(ModelObject, CoordinateSystem, CoordinateSystem)
Moves the model object between the given translation coordinate systems.
Public methodStatic memberObjectMatchesToFilter(ModelObject, String)
Checks whether the object matches to the criteria in the given filter.
Public methodStatic memberCode exampleObjectMatchesToFilter(ModelObject, FilterExpression)
Checks whether the object matches to the criteria in the given filter.
Public methodStatic memberOpen(String) Obsolete.
Opens a new model to Tekla Structures ignoring auto saved information.
Public methodStatic memberOpen(String, Boolean) Obsolete.
Opens a new model to Tekla Structures.
Public methodStatic memberCode exampleRemoveFromPourUnit
Removes model object from pour unit Model object types accepted are assembly types except cast in situ, reinforcements of different kind, components and bolts
Public methodStatic memberCode exampleRunMacro
Starts a macro with the given name. Throws an exception if the file is not found.

Macros are saved as *.cs files in the folder defined with the XS_MACRO_DIRECTORY variable.

It is possible to run drawing macros using relative paths.

See Tekla Structures Help for more information about macros.

Public methodStatic memberSaveAsWebModel
Saves the current model as a web model.

You can save the model as a web model that can be viewed via the Internet using a web browser (e.g. Internet Explorer).

Public methodStatic memberSaveSelectedAsWebModel
Saves the selected objects as a web model.

You can save the selected objects as a web model that can be viewed via the Internet using a web browser (e.g. Internet Explorer).

Public methodStatic memberSetHandlePoints
Set the Shape Item Handle Points
Public methodStatic memberShowOnlySelected
Show Only Selected objects in current view.
Public methodStatic memberSplit(Beam, Point)
Splits the beam and creates a new one in the given position.
Public methodStatic memberSplit(CircleRebarGroup, Line)
Splits the circle rebar group and creates a new one in the given position.
Public methodStatic memberSplit(ContourPlate, Polygon)
Splits the contour plate and creates a new one along the given polygon.
Public methodStatic memberSplit(CurvedRebarGroup, Line)
Splits the curved rebar group and creates a new one in the given position.
Public methodStatic memberSplit(LoftedPlate, Point)
Splits the lofted plate and creates a new one in the given position.
Public methodStatic memberSplit(PolyBeam, Point)
Splits the polybeam and creates a new one in the given position.
Public methodStatic memberSplit(RebarGroup, Line)
Splits the rebar group and creates a new one in the given position.
Public methodStatic memberSplit(SingleRebar, Line)
Splits the single rebar and creates a new one in the given position.
Public methodStatic memberSplitSlab
This command is meant for specifically splitting a concrete slab with advanced solid operations to create more robust and user friendly results than the command: public static ContourPlate Split(ContourPlate Object, Polygon SplitPolygon). No validation is done for the type, it is the caller's responsibility to call this only for valid types (slabs). Behavior for non-slabs is undetermined.
Public methodStatic memberUngrouping(RebarGroup)
Ungroups the rebar group and creates new single rebars.
Public methodStatic memberUngrouping(RebarMesh)
Ungroups the rebar mesh and creates new single rebars.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next