GridPlane Class

The GridPlane class defines a user defined (possibly magnetic) plane helping in modeling work. A grid plane must always belong to a father grid instance.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridPlane : GridSurface

The GridPlane type exposes the following members.

Constructors
  NameDescription
Public methodGridPlane
Creates a new grid plane instance.

The default values are as follows:

  • Plane = new Plane();
  • Plane.Origin = new Point(500.0, 500.0, 0.0);
  • Plane.AxisX = new Vector(2000.0, 0.0, 0.0);
  • Plane.AxisY = new Vector(0.0, 0.0, 2000.0);
  • Label = "Default";
  • IsMagnetic = false;
  • ExtensionLeft = 2000.0;
  • ExtensionRight = 2000.0;
  • ExtensionBelow = 2000.0;
  • ExtensionAbove = 2000.0;
  • DrawingVisibility = false;
Public methodGridPlane(Plane, String)
Creates a new grid plane instance taking the plane and label as input.
Top
Properties
  NameDescription
Public propertyColor Obsolete.
The color of the grid plane. This works only in wireframe views. The color of grid planes in rendered views can be changed using the advanced option XS_GRID_COLOR.
Public propertyDrawingVisibility
The visibility of the grid surface in drawings.
Public propertyExtensionAbove
The line extension above.
Public propertyExtensionBelow
The line extension below.
Public propertyExtensionForMagneticArea Obsolete.
The extension for the magnetic area.
Public propertyExtensionLeft
The line extension on the left.
Public propertyExtensionRight
The line extension on the right.
Public propertyFather Obsolete.
The father grid of the grid plane.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsMagnetic
Whether the grid surface is magnetic or not.
Public propertyIsManual
Gets or sets if the line was manually created.
(Inherited from GridSurface.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLabel
The label for the grid surface.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyParent
The parent grid of the grid surface.
(Inherited from GridSurface.)
Public propertyPlane
The plane defining the position of the grid plane.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the grid surface with the given ID.
(Overrides GridSurfaceDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the grid surface into the model.
(Overrides GridSurfaceInsert.)
Public methodModify
Modifies the grid plane with the given ID.
(Overrides GridSurfaceModify.)
Public methodSelect
Selects the grid surface with the given ID.
(Overrides GridSurfaceSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           GridPlane GridPlane = new GridPlane();

           Plane plane = new Plane();
           plane.Origin = new Point(6000,6000,0);
           plane.AxisX = new Vector(-3000,0,0);
           plane.AxisY = new Vector(0,6000,0);

           GridPlane.Plane = plane;
           GridPlane.IsMagnetic = true;

           bool Result = false;
           Result = GridPlane.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next