GridPlane Class

The GridPlane class defines a user defined (possibly magnetic) plane helping in modeling work. A grid plane must always belong to a father grid instance.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridPlane : GridSurface

The GridPlane type exposes the following members.

Constructors
  NameDescription
Public methodGridPlane
Creates a new grid plane instance.

The default values are as follows:

  • Plane = new Plane();
  • Plane.Origin = new Point(500.0, 500.0, 0.0);
  • Plane.AxisX = new Vector(2000.0, 0.0, 0.0);
  • Plane.AxisY = new Vector(0.0, 0.0, 2000.0);
  • Label = "Default";
  • IsMagnetic = false;
  • ExtensionLeft = 2000.0;
  • ExtensionRight = 2000.0;
  • ExtensionBelow = 2000.0;
  • ExtensionAbove = 2000.0;
  • DrawingVisibility = false;
Public methodGridPlane(Plane, String)
Creates a new grid plane instance taking the plane and label as input.
Top
Properties
  NameDescription
Public propertyColor Obsolete.
The color of the grid plane. This works only in wireframe views. The color of grid planes in rendered views can be changed using the advanced option XS_GRID_COLOR.
Public propertyDrawingVisibility
The visibility of the grid surface in drawings.
Public propertyExtensionAbove
The line extension above.
Public propertyExtensionBelow
The line extension below.
Public propertyExtensionForMagneticArea Obsolete.
The extension for the magnetic area.
Public propertyExtensionLeft
The line extension on the left.
Public propertyExtensionRight
The line extension on the right.
Public propertyFather Obsolete.
The father grid of the grid plane.
Public propertyIsMagnetic
Whether the grid surface is magnetic or not.
Public propertyLabel
The label for the grid surface.
Public propertyPlane
The plane defining the position of the grid plane.
Top
Methods
  NameDescription
Public methodDelete
Deletes the grid surface with the given ID.
(Overrides GridSurfaceDelete.)
Public methodInsert
Inserts the grid surface into the model.
(Overrides GridSurfaceInsert.)
Public methodModify
Modifies the grid plane with the given ID.
(Overrides GridSurfaceModify.)
Public methodSelect
Selects the grid surface with the given ID.
(Overrides GridSurfaceSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           GridPlane GridPlane = new GridPlane();

           Plane plane = new Plane();
           plane.Origin = new Point(6000,6000,0);
           plane.AxisX = new Vector(-3000,0,0);
           plane.AxisY = new Vector(0,6000,0);

           GridPlane.Plane = plane;
           GridPlane.IsMagnetic = true;

           bool Result = false;
           Result = GridPlane.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next