PolymeshPolymeshHealthCheckEnum Enumeration

Polymesh check error result codes. See the PolymeshCheckerFlags to see how to set the various checks.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum PolymeshHealthCheckEnum
Members
  Member nameValueDescription
PolymeshLevelError-2 The vertex array contains vertices that are geometrically equivalent or the polymesh contains unused vertices
PolymeshUndefined-1 Polymesh is null, the creation failed or unknown reasons.
PolymeshOk0 Valid polymesh
NumOfVerticesOuterloop1 Number of vertices in outer loop too small
NumOfVerticesInnerloop2 Number of vertices in innerloop too small
VertexArrayOuterloop3 Check of indices of vertices in outer loop failed
VertexArrayInnerloop4 Check of indices of vertices in the innerloop failed
InnerloopNotInsideOuterloop5 Inner loop is not inside the outer loop
VertexArrayForListOfEdges6 Check of indices of vertices for edge list failed
NonPlanarOuterloop7 Outer loop points are not in the same plane with each other
NonPlanarInnerloop8 Inner loop points are not in the same plane with each other or with outer loop
SelfIntersectingOuterloop9 Outer loop is self-intersecting
SelfIntersectingInnerloop10 Inner loop is self-intersecting
LoopNormalsInvalid11 Inner loop normal direction should be opposite to outer loop
FaceEdgesInvalidOrientation12 Two neighbor faces with common edge have wrong orientation
FaceEdgesPartlyInvalidOrientation13 Two neighbor faces with partly common edge have wrong orientation
MultishellPolymesh14 Polymesh consists topologically of multiple shells
MultishellPolymeshByGeometry21 Polymesh consists geometrically of multiple shells
NumberOfFaces15 Number of faces too small
VertexArrayUniqueness16 The vertex array contains vertices that are geometrically equivalent
VertexDuplicatesOnPolygon17 The same vertex index appears at least twice for a face
VertexCollinearOnPolygon18 The face has at least one vertex that is collinear with others on an edge
NonManifoldEdges19 The polymesh contains non-manifold edges
UnusedVertices20 The polymesh contains unused vertices
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next