UserDefinedElement Class

The UserDefinedElement class represents a user-defined attribute specified by its name. A user-defined element is converted into a textual value before it is drawn.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class UserDefinedElement : ElementBase

The UserDefinedElement type exposes the following members.

Constructors
  NameDescription
Public methodUserDefinedElement(String)
Creates a new user-defined element instance with the given name.
Public methodUserDefinedElement(String, FontAttributes)
Creates a new user-defined element instance with the given name and font.
Top
Properties
  NameDescription
Public propertyFont
The font of the user-defined attribute.
Public propertyName
The name of the user-defined attribute.
Public propertyUnit
Gets or sets the unit attributes.
Public propertyValue
The value of the user-defined attribute.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next