RebarHookData Class

The RebarHookData class defines the hook at the end of a reinforcing bar. Hooks are used for anchoring purposes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarHookData

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarHookData

The RebarHookData type exposes the following members.

Constructors
  NameDescription
Public methodRebarHookData
Instantiates a rebar hook data instance with empty members.
Top
Properties
  NameDescription
Public propertyAngle
The angle of the hook. The value is between -270 to +270 degrees.
Public propertyLength
The length of the straight part of the hook.
Public propertyRadius
The bending radius of the hook.
Public propertyShape
Defines the shape of the hook. The options are:
  • NO_HOOK. Sets the angle, radius and length to 0.
  • HOOK_90_DEGREES.
  • HOOK_135_DEGREES.
  • HOOK_180_DEGREES.
  • CUSTOM_HOOK. The angle, radius and length values have to be set manually.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next