ModificationStamp Class

The ModificationStamp class provides the modification stamp for the objects of the model that is currently open in Tekla Structures.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.HistoryModificationStamp

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ModificationStamp

The ModificationStamp type exposes the following members.

Constructors
  NameDescription
Public methodModificationStamp
Creates a new modification stamp instance where the current modification stamp is 0. Can be used for fetching all the created or deleted model objects from the model history.
Public methodModificationStamp(Int32, Int32)
Creates a new modification stamp instance with the given local and server stamps. Can be used for fetching from the model history all the model objects that have been created or deleted after the specified stamp.
Top
Properties
  NameDescription
Public propertyGuid
Guid representation
Public propertyLocalStamp
The modification stamp for the local changes.
Public propertyServerStamp
The modification stamp from the multi-user server for the external changes caused by the saving of the multi-user model.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next