LineTypes Class

The LineTypes class defines the possible line types that can be used by the drawing objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class LineTypes : IIsEqual, 
	ICloneable

The LineTypes type exposes the following members.

Methods
  NameDescription
Public methodClone
Creates a new object that is a copy of the current instance.
Public methodStatic memberCustom
The Custom line type defines a line that is drawn using one of the custom line types, as specified by the CustomLineTypeName.
Public methodEquals
Returns true if the current object and the given object are equal.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Returns a hash code for the object.
(Overrides ObjectGetHashCode.)
Public methodIsEqual
Compares the current object with an object of the same type.
Public methodToString
Returns the LineTypes information as a string.
(Overrides ObjectToString.)
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Returns true if the current object and the given object are equal.
Public operatorStatic member(Int32 to LineTypes)
Returns the corresponding LineTypes value of the given int value.
Public operatorStatic member(LineTypes to Int32)
Returns the corresponding int value of the given LineTypes value.
Public operatorStatic memberInequality
Returns true if the current object and the given object are not equal.
Top
Fields
  NameDescription
Public fieldStatic memberDashDot
The dash dotted line (--.--.).
Public fieldStatic memberDashDoubleDot
The dash double dotted line (-..-..-).
Public fieldStatic memberDashedLine
The dashed line (-----).
Public fieldStatic memberDottedLine
The dotted line (.....).
Public fieldStatic memberSlashDash
The slash dash line (-- - -- -).
Public fieldStatic memberSlashedLine
The slashed line (- - -).
Public fieldStatic memberSolidLine
The solid line (default).
Public fieldStatic memberUndefinedLine
The line type is undefined.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next