PrinterItem Class

The PrinterItem class contains information about the printers in the Tekla Structures catalog.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsPrinterItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class PrinterItem

The PrinterItem type exposes the following members.

Constructors
  NameDescription
Public methodPrinterItem
Creates a new printer item instance.
Top
Properties
  NameDescription
Public propertyDevice
The actual printer device used in the printing.
Public propertyExtension
The printer item's default file extension which is used when printing to a file.
Public propertyName
The printer item's name which Tekla Structures uses to fetch all the item's default properties in the printing process.
Public propertyPrintAreaHeigth
The printer item's print area height.
Public propertyPrintAreaWidth
The printer item's print area width.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next