GeometricPlane Class

The GeometricPlane class represents a 3d geometric plane.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dGeometricPlane

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class GeometricPlane

The GeometricPlane type exposes the following members.

Constructors
  NameDescription
Public methodGeometricPlane
Instantiates an XY-plane with the origin at (0,0,0).
Public methodGeometricPlane(CoordinateSystem)
Instantiates a plane defined by the given coordinate system.
Public methodGeometricPlane(Point, Vector)
Instantiates a plane defined by the given origin point and normal vector.
Public methodGeometricPlane(Point, Vector, Vector)
Instantiates a plane defined by the given origin, X-axis vector and Y-axis vector.
Top
Properties
  NameDescription
Public propertyNormal
The normal vector of the plane.
Public propertyOrigin
The origin point of the plane.
Top
Methods
  NameDescription
Public methodGetNormal
Returns a normalized normal vector of the plane.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next