WpfReinforcementCatalog Class

The WpfReinforcementCatalog class represents a group of controls to select rebars using the reinforcement catalog.
WpfReinforcementCatalog
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class WpfReinforcementCatalog : UserControl, 
	IComponentConnector

The WpfReinforcementCatalog type exposes the following members.

Constructors
  NameDescription
Public methodWpfReinforcementCatalog
Initiates a new instance of the control.
Public methodWpfReinforcementCatalog(String, String, Double)
Creates a new instance of the ReinforcementCatalog and will select in the tree the rebar that contains the given parameters (if possible).
Top
Properties
  NameDescription
Public propertyButtonHeight
Gets and sets the height of the button control.
Public propertyButtonText
Gets and sets the text of the button control.
Public propertyButtonWidth
Gets and sets the width of the button control.
Public propertySelectedRebarBendingRadius
Gets the selected rebar bending radius in the control.
Public propertySelectedRebarGrade
Gets the selected rebar grade in the control.
Public propertySelectedRebarSize
Gets the selected rebar size in the control.
Public propertySelectedUsage
Gets the selected rebar usage in the control.
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Public methodOnValueChanged
Event handler for passing generic catalog data back to dialog
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next