ReinforcementBaseReinforcementMeshAttributes Class

The ReinforcementMeshAttributes class is the base attributes class for ReinforcementMesh.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ReinforcementMeshAttributes : ReinforcementBaseReinforcementBaseAttributes

The ReinforcementBaseReinforcementMeshAttributes type exposes the following members.

Constructors
  NameDescription
Public methodReinforcementBaseReinforcementMeshAttributes
Creates a new default reinforcement attributes instance that loads standard attributes.
Public methodReinforcementBaseReinforcementMeshAttributes(Boolean)
Creates a new default reinforcement attributes instance that loads standard attributes. If it set to true attributes won't be lodaded.
Public methodReinforcementBaseReinforcementMeshAttributes(String)
Creates a new reinforcement attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHiddenLines
The line type of the hidden lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHideLinesHiddenByPart
Defines whether lines hidden by parts should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyHideLinesHiddenByReinforcement
Defines whether lines hidden by reinforcements should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyMeshReinforcementSymbolIndex
Defines the index for the mesh symbol to be used. The mesh symbol appears in the middle of the mesh line when ReinforcementRepresentation == OutLine. The index starts from 0 and corresponds to the symbol in the file mesh.sym.
Public propertyMeshReinforcementSymbolSize
Defines the size of the reinforcement mesh symbol.
Public propertyMeshReinforcementVisibilityCrossing
Defines which crossing bars in the mesh appear in drawings.
Public propertyMeshReinforcementVisibilityLongitudinal
Defines which longitudinal wires in the mesh appear in drawings.
Public propertyReinforcementRepresentation
The representation of reinforcing bars.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Public propertyVisibleLines
The line type of the visible lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.)
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next