DrawingCoordinateConverterConvert Method (ViewBase, ViewBase, PointList)

Converts a list of coordinate points from one view's coordinate system to another view's coordinate system.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static PointList Convert(
	ViewBase fromView,
	ViewBase toView,
	PointList pointList
)

Parameters

fromView
Type: Tekla.Structures.DrawingViewBase
The source view.
toView
Type: Tekla.Structures.DrawingViewBase
The target view.
pointList
Type: Tekla.Structures.DrawingPointList
The list of points to be converted.

Return Value

Type: PointList
The converted list of points.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next