MeshCatalog Class

The MeshCatalog class represents a group of controls to select meshes using the mesh catalogs.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class MeshCatalog : UserControl

The MeshCatalog type exposes the following members.

Constructors
  NameDescription
Public methodMeshCatalog
Initiates a new instance of the control.
Top
Properties
  NameDescription
Public propertyButtonText
Gets and sets the text of the button control.
Public propertySelectedMeshGrade
The mesh grade in the control.
Public propertySelectedMeshName
The mesh name in the control.
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next