ModelInfo Class

The ModelInfo class provides information about the currently open Tekla Structures model.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelModelInfo

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ModelInfo

The ModelInfo type exposes the following members.

Properties
  NameDescription
Public propertyCurrentPhase
The number of the Tekla Structures model's current phase.
Public propertyModelName
The name of the Tekla Structures model.
Public propertyModelPath
The path to the Tekla Structures model.
Public propertyNorthDirection
The north direction of the current Tekla Structures model.
Public propertySharedModel
The read-only property of the Tekla Structures model's sharing status.
Public propertySingleUserModel
The read-only property if the Tekla Structures model is a single user model.
Top
Examples
When Tekla Structures is running the length of the model name tells you whether the model is open.
using Tekla.Structures.Model;
using System.Windows.Forms;

public class Example
{
    public void Example1()
    {
        Model CurrentModel = new Model();
        ModelInfo Info = CurrentModel.GetInfo();

        if (CurrentModel.GetConnectionStatus())
        {
            if (Info.ModelName.Length == 0)
            {
                MessageBox.Show("A Tekla Structures model is not open.");
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next