Circle Constructor (ViewBase, Point, Double, CircleCircleAttributes)

Creates a new circle instance with a center point and a radius using the given attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public Circle(
	ViewBase view,
	Point centerPoint,
	double radius,
	CircleCircleAttributes attributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
centerPoint
Type: Tekla.Structures.Geometry3dPoint
The center point to be used.
radius
Type: SystemDouble
The radius to be used.
attributes
Type: Tekla.Structures.DrawingCircleCircleAttributes
The circle attributes to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next