Tekla.Structures.Catalogs Namespace

The Tekla.Structures.Catalogs namespace includes the functionality to access Tekla Structures catalog instances, such as the profile or rebar catalog.
Classes
  ClassDescription
Public classBoltItem
The BoltItem class contains information about the bolts in the Tekla Structures bolt catalog.
Public classCode exampleBoltItemEnumerator
The BoltItemEnumerator class allows to loop through the bolt catalog items.
Public classBoltName
The BoltName class contains the name of the bolt item.
Public classCatalogHandler
The CatalogHandler class is a class from which the user can query catalog instances.
Public classCatalogItemEnumeratorInitializationException
The CatalogItemEnumeratorInitializationException class represents an error that occurred during the catalog item enumerator initialization. This class cannot be inherited.
Public classComponentItem
The ComponentItem class contains information about the components in the Tekla Structures catalog.
Public classCode exampleComponentItemEnumerator
The ComponentItemEnumerator class allows to loop through the component catalog items.
Public classCode exampleCrossSection
The CrossSection class defines a with cross section points
Public classCrossSectionPoint
The CrossSectionPoint class defines a point with possible chamfering information
Public classDrawingItem
The DrawingItem class contains information from the drawings in the master drawing catalog.
Public classDrawingItemEnumerator
The DrawingItemEnumerator class allows to loop through the catalog drawing items.
Public classCode exampleLibraryProfileItem
The LibraryProfileItem class contains information from library profiles in the catalog. Library profile items can be enumerated using a profile item enumerator.
Public classMaterialItem
The MaterialItem class contains information about the materials in the Tekla Structures catalog.
Public classCode exampleMaterialItemEnumerator
The MaterialItemEnumerator class allows to loop through the catalog material items.
Public classMaterialMarketSizesItem
The MaterialMarketSizesItem class contains information about the available market sizes for particular material.
Public classCode exampleMaterialMarketSizesItemEnumerator
The MaterialMarketSizesItemEnumerator class allows to loop through the items defined in XS_PROFDB\marketsizes.dat file.
Public classMaterialName
The MaterialName class contains the name of the material item.
Public classMeshItem
The MeshItem class contains information from the meshes in the catalog (mesh_database.inp).
Public classMeshItemEnumerator
The MeshItemEnumerator class allows to loop through the catalog mesh items.
Public classCode exampleParametricProfileItem
The ParametricProfileItem class contains information from parametric profiles in the catalog. Parametric profile items can be enumerated using a profile item enumerator.
Public classPrinterItem
The PrinterItem class contains information about the printers in the Tekla Structures catalog.
Public classCode examplePrinterItemEnumerator
The PrinterItemEnumerator class allows to loop through the catalog printer items.
Public classProfileItem
The ProfileItem abstract class contains the common information of catalog profiles (parametric and library).
Public classCode exampleProfileItemEnumerator
The ProfileItemEnumerator class allows to loop through the catalog profile items.
Public classProfileItemParameter
The ProfileItemParameter class contains the information of one profile parameter (property name, symbol, unit and unit type). A profile item can contain a maximum of 50 profile parameters.
Public classProfileName
The ProfileName class contains the name of the profile item.
Public classRebarHeaderItem
The RebarHeaderItem class represents an item in the header of the rebar catalog (rebar_database.inp).
Public classRebarItem
The RebarItem class contains information from the rebars in the catalog (rebar_database.inp).
Public classRebarItemEnumerator
The RebarItemEnumerator class allows to loop through the catalog rebar items.
Public classCode exampleShapeItem
The Shape class contains information about the shapes in the Tekla Structures shape catalog.
Public classCode exampleShapeItemEnumerator
The ShapeItemEnumerator class allows to loop through the shape catalog items.
Public classUserPropertyItem
The UserPropertyItem class contains information about the user properties in the Tekla Structures catalog.
Public classCode exampleUserPropertyItemEnumerator
The UserPropertyItemEnumerator class allows to loop through the user property items.
Public classUserPropertyName
The UserPropertyName class contains the name of the user property item.
Public classUserPropertyOption
The UserPropertyOption class contains the properties of a user property value option.
Enumerations
  EnumerationDescription
Public enumerationBoltItemBoltItemTypeEnum
Defines the different bolt item types.
Public enumerationBrepType
Shape catalog renewal makes it possible to organize shapes in the shape catalog compared to a plain list before. Thus, it is now possible and required to distinguish shapes in such a manner that: BuildingProduct represent shapes that users can import from, for example, Tekla Warehouse and insert them into a model. These are usually provided by the manufacturer and not detailed by users themselves. StructuralShape represent shapes that get created by "Convert part to item" or from geometry editing.
Public enumerationCatalogObjectTypeEnum
The catalog object type.
Public enumerationComponentItemComponentTypeEnum
Defines the different component types.
Public enumerationMaterialItemMaterialItemTypeEnum
Defines the different material item types.
Public enumerationProfileItemProfileItemSubTypeEnum
Defines the different profile item subtypes.
Public enumerationProfileItemProfileItemTypeEnum
Defines the different profile item types.
Public enumerationProfileItemParameterParameterUnitTypeEnum
Defines the different unit types of the profile item parameter.
Public enumerationShapeUpAxis
Up axis direction
Public enumerationUserPropertyFieldTypeEnum
The user property field type.
Public enumerationUserPropertyLevelEnum
The user property level.
Public enumerationUserPropertyVisibilityEnum
The visibility of the user property.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next