Text Constructor (ViewBase, Point, String, PlacingBase, TextTextAttributes)

Creates a new text instance with the given text string and text attributes using a specific placing type.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public Text(
	ViewBase view,
	Point insertionPoint,
	string Text,
	PlacingBase Placing,
	TextTextAttributes inAttributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The insertion point to be used.
Text
Type: SystemString
The text string to be used.
Placing
Type: Tekla.Structures.DrawingPlacingBase
The placing type to be used.
inAttributes
Type: Tekla.Structures.DrawingTextTextAttributes
The text attributes to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next