Double Structure

The Double datatype.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
[TypeConverterAttribute(typeof(DoubleConverter))]
public struct Double : IXmlSerializable, IDoubleDataType, 
	IDataType, IEquatable<Double>, IComparable<Double>

The Double type exposes the following members.

Constructors
  NameDescription
Public methodDouble
Creates a new double datatype instance.
Top
Properties
  NameDescription
Public propertyValue
The value of the double datatype.
Top
Methods
  NameDescription
Public methodCompareTo
Compares the current object with another object of the same type.
Public methodEquals(Object)
Returns a value that indicates whether the current instance is equal to the given object.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Double)
Indicates whether the current object is equal to another object of the same type.
Public methodGetHashCode
Returns the hash code for the current instance.
(Overrides ValueTypeGetHashCode.)
Public methodGetSchema
Gets the XML Schema for the datatype.
Public methodReadXml
Parses a new value from the given reader.
Public methodToString
Returns the string representation of the object.
(Overrides ValueTypeToString.)
Public methodWriteXml
Writes the value as XML to the given writer.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Compares a double value with a Datatype.Double value.
Public operatorStatic member(Double to Double)
Converts from double to Datatype.Double.
Public operatorStatic member(Double to Double)
Converts from Datatype.Double to double.
Public operatorStatic memberInequality
Compares a double value with a Datatype.Double value.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next