SymbolInfo Class

The SymbolInfo class holds symbol information: the symbol file and the symbol index in the symbol file.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingSymbolInfo

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SymbolInfo : IIsEqual

The SymbolInfo type exposes the following members.

Constructors
  NameDescription
Public methodSymbolInfo
Creates a new symbol info instance.
Public methodSymbolInfo(String, Int32)
Creates a new symbol info instance.
Top
Properties
  NameDescription
Public propertySymbolFile
Gets or sets the symbol file. E.g. "xsteel".
Public propertySymbolIndex
Gets or sets the the symbol index. Throws an ArgumentOutOfRangeException if the symbol index is not in the range from 0 to 255.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
Top
Fields
  NameDescription
Public fieldStatic memberDefault
The default symbol information: the symbol 0 in the xsteel library.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next