Tekla.Structures.Solid Namespace

The Tekla.Structures.Solid namespace contains basic common solid related types that are shared between Tekla Structures Model and Drawing.
Classes
  ClassDescription
Public classEdge
The Edge class represents a single global edge in a solid.
Public classCode exampleEdgeEnumerator
The EdgeEnumerator class is used to enumerate the edges of a solid.
Public classFace
The Face class represents a single face in a solid.
Public classFaceEnumerator
The FaceEnumerator class is used to enumerate the faces of a solid.
Public classLoop
The Loop class represents a single loop in a face.
Public classLoopEnumerator
The LoopEnumerator class is used to enumerate the loops of a face instance.
Public classShell
The Shell class represents a single shell in a solid.
Public classCode exampleShellEnumerator
The ShellEnumerator class is used to enumerate the shells of a solid.
Public classVertexEnumerator
The VertexEnumerator class is used to enumerate the vertexes of a loop instance.
Interfaces
  InterfaceDescription
Public interfaceISolid
The ISolid interface represents a physical object in the model or a drawing created by a part instance. The solid instance can be used to query the actual geometry of the part.
Enumerations
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next