View Class

The View class contains methods related to views. Views are views that contain other drawing objects, excluding other views. Views also contain drawing representations of model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class View : ViewBase

The View type exposes the following members.

Constructors
  NameDescription
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, ArrayList)
Creates a new view instance with the given coordinate systems and part list.
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, AABB)
Creates a new view instance with the given coordinate systems and model area.
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, ArrayList, String)
Creates a new view instance with the given coordinate systems, part list and attributes file's filename.
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, AABB, String)
Creates a new view instance with the given coordinate systems, model area and attributes file's filename.
Top
Properties
  NameDescription
Public propertyAttributes
The view attributes.
Public propertyDisplayCoordinateSystem
The coordinate system of the display plane. This can be used to transform global points from the model that is to be inserted in the view.
Public propertyExtremaCenter
Gets the view extrema center.
(Inherited from ViewBase.)
Public propertyFrameOrigin
The vector from the view origin to the frame origin.
(Inherited from ViewBase.)
Public propertyHeight
The height of the view frame in paper coordinates.
(Inherited from ViewBase.)
Public propertyIsSheet
Gets a value indicating whether the container view is the drawing's sheet.
(Inherited from ViewBase.)
Public propertyName
The name of the view.
Public propertyOrigin
The view origin coordinates in the sheet.
(Inherited from ViewBase.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyRestrictionBox
The axis aligned bounding box that represents the volume of the view.
Public propertyViewCoordinateSystem
The coordinate system of the view plane.
Public propertyViewType
The view type information.
Public propertyWidth
The width of the view frame in paper coordinates.
(Inherited from ViewBase.)
Top
Methods
  NameDescription
Public methodStatic memberCreate3dView(Drawing, Point, ViewViewAttributes, View)
Generates a new 3d view on the sheet of the given drawing.
Public methodStatic memberCreate3dView(Drawing, CoordinateSystem, CoordinateSystem, AABB, Point, ViewViewAttributes, View)
Generates a new 3d view on the sheet of the given drawing using given view plane and display plane.
Public methodStatic memberCreateBackView
Generates a new back view on the sheet of the given drawing.
Public methodStatic memberCreateBottomView
Generates a new bottom view on the sheet of the given drawing.
Public methodStatic memberCreateCurvedSectionView
Generates a new curved section view on the sheet and the associated section mark for the specified view.
Public methodStatic memberCreateDetailView
Generates a new detail view on the sheet and the associated detail mark for the specified view.
Public methodStatic memberCreateFrontView
Generates a new front view on the sheet of the given drawing.
Public methodStatic memberCreateSectionView
Generates a new section view on the sheet and the associated section mark for the specified view.
Public methodStatic memberCreateTopView
Generates a new top view on the sheet of the given drawing.
Public methodDelete
Deletes the view and its children objects from the database.
(Inherited from ViewBase.)
Public methodGetAllObjects
Gets all the objects and their children objects in the view.
(Inherited from ViewBase.)
Public methodGetAllObjects(Type)
Gets all the objects and their children objects in the view that are of a certain type.
(Inherited from ViewBase.)
Public methodGetAllObjects(Type)
Gets all the objects and their children objects in the view that are of certain types.
(Inherited from ViewBase.)
Public methodGetAxisAlignedBoundingBox
The view size in paper coordinates.
(Inherited from ViewBase.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetModelObjects
Gets the model objects that are in the view.
Public methodGetModelObjects(Identifier)
Gets the drawing model objects based on given model object identifier. If used from sheet model objects from all views are returned.
(Inherited from ViewBase.)
Public methodGetObjects
Gets the objects in the view. Does not return child objects (single dimensions, grid lines, views).
(Inherited from ViewBase.)
Public methodGetObjects(Type)
Gets the objects in the view that are of certain types. Does not return child objects (single dimensions, grid lines, views).
(Inherited from ViewBase.)
Public methodGetOriginalDrawing
Gets the drawing on which the view was originally created. @see DrawingObject.GetDrawing() for retrieving the current drawing the object resides on.
(Inherited from ViewBase.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetVisibleAreaRestrictionBoxes
Gets the restriction boxes that represent the visible areas of the view.
Public methodInsert
Inserts the view to the database.
(Inherited from ViewBase.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides ViewBaseIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the view in the database.
(Inherited from ViewBase.)
Public methodRotateViewOnAxisX
Rotate the view on the X axis.
Public methodRotateViewOnAxisY
Rotate the view on the Y axis.
Public methodRotateViewOnAxisZ
Rotate the view on the Z axis.
Public methodRotateViewOnDrawingPlane
Rotate the view on the drawings plane. This works just like the user interface command "Rotate view".
Public methodSelect
Selects the view from the database.
(Inherited from ViewBase.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
The following example creates and inserts a new view to the active drawing. A drawing must be open when executing the code.
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               Drawing Drawing = MyDrawingHandler.GetActiveDrawing();
               CoordinateSystem CoordinateSystem = new CoordinateSystem(new Point(), new Vector(1, 0, 0), new Vector(0, 1, 0));

               View newView = new View(Drawing.GetSheet(), CoordinateSystem, CoordinateSystem, new AABB(new Point(0, 0), new Point(1000, 1000, 1000)));
               newView.Insert();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next