View Class

The View class contains methods related to views. Views are views that contain other drawing objects, excluding other views. Views also contain drawing representations of model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class View : ViewBase

The View type exposes the following members.

Constructors
  NameDescription
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, ArrayList)
Creates a new view instance with the given coordinate systems and part list.
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, AABB)
Creates a new view instance with the given coordinate systems and model area.
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, ArrayList, String)
Creates a new view instance with the given coordinate systems, part list and attributes file's filename.
Public methodView(ContainerView, CoordinateSystem, CoordinateSystem, AABB, String)
Creates a new view instance with the given coordinate systems, model area and attributes file's filename.
Top
Properties
  NameDescription
Public propertyAttributes
The view attributes.
Public propertyDisplayCoordinateSystem
The coordinate system of the display plane. This can be used to transform global points from the model that is to be inserted in the view.
Public propertyName
The name of the view.
Public propertyRestrictionBox
The axis aligned bounding box that represents the volume of the view.
Public propertyViewCoordinateSystem
The coordinate system of the view plane.
Public propertyViewType
The view type information.
Top
Methods
  NameDescription
Public methodStatic memberCreate3dView(Drawing, Point, ViewViewAttributes, View)
Generates a new 3d view on the sheet of the given drawing.
Public methodStatic memberCreate3dView(Drawing, CoordinateSystem, CoordinateSystem, AABB, Point, ViewViewAttributes, View)
Generates a new 3d view on the sheet of the given drawing using given view plane and display plane.
Public methodStatic memberCreateBackView
Generates a new back view on the sheet of the given drawing.
Public methodStatic memberCreateBottomView
Generates a new bottom view on the sheet of the given drawing.
Public methodStatic memberCreateCurvedSectionView
Generates a new curved section view on the sheet and the associated section mark for the specified view.
Public methodStatic memberCreateDetailView
Generates a new detail view on the sheet and the associated detail mark for the specified view.
Public methodStatic memberCreateFrontView
Generates a new front view on the sheet of the given drawing.
Public methodStatic memberCreateSectionView
Generates a new section view on the sheet and the associated section mark for the specified view.
Public methodStatic memberCreateTopView
Generates a new top view on the sheet of the given drawing.
Public methodGetModelObjects
Gets the model objects that are in the view.
Public methodGetVisibleAreaRestrictionBoxes
Gets the restriction boxes that represent the visible areas of the view.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides ViewBaseIsEqual(Object).)
Public methodRotateViewOnAxisX
Rotate the view on the X axis.
Public methodRotateViewOnAxisY
Rotate the view on the Y axis.
Public methodRotateViewOnAxisZ
Rotate the view on the Z axis.
Public methodRotateViewOnDrawingPlane
Rotate the view on the drawings plane. This works just like the user interface command "Rotate view".
Top
Examples
The following example creates and inserts a new view to the active drawing. A drawing must be open when executing the code.
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               Drawing Drawing = MyDrawingHandler.GetActiveDrawing();
               CoordinateSystem CoordinateSystem = new CoordinateSystem(new Point(), new Vector(1, 0, 0), new Vector(0, 1, 0));

               View newView = new View(Drawing.GetSheet(), CoordinateSystem, CoordinateSystem, new AABB(new Point(0, 0), new Point(1000, 1000, 1000)));
               newView.Insert();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next