DimensionSetBaseAttributes Class

The DimensionSetBaseAttributes class is the base class for all dimension set attributes. The class contains attributes that are common to all dimension sets.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class DimensionSetBaseAttributes : AttributesBase

The DimensionSetBaseAttributes type exposes the following members.

Constructors
  NameDescription
Public methodDimensionSetBaseAttributes
Creates a new default dimension set base attributes instance that loads standard attributes.
Public methodDimensionSetBaseAttributes(String)
Creates a new dimension set base attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyArrowhead
The arrowhead attributes of the dimension.
Public propertyColor
The color of the dimension line.
Public propertyFormat
The format attributes of the dimension.
Public propertyPlacing
The placing attributes of the dimension.
Public propertyText
The text attributes of the dimension.
Public propertyTransparentBackground
The dimension text background transparency. (transparent/opaque)
Top
Methods
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next