CustomPartInputTypeAttribute Class

The CustomPartInputTypeAttribute class is used for defining the input type. Based on the type the system will then ask for the correct number of input points in the creation. The attribute is initialized from the custom attribute [CustomPartInputType(CustomPartBase.CustomPartInputType.INPUT_1_POINT)] in the custom part source code.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsCustomPartInputTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class CustomPartInputTypeAttribute : Attribute

The CustomPartInputTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodCustomPartInputTypeAttribute(Int32)
The custom attribute uses this to store the input type to the system. This is not to be used by itself.
Public methodCustomPartInputTypeAttribute(CustomPartBaseCustomPartInputType)
The custom attribute uses this to store the input type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute uses this to store the input type to the system. This is not to be used by itself.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next