WpfMeshCatalog Class

The WpfMeshCatalog class represents a group of controls to select meshes using the mesh catalog.
WpfMeshCatalog
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class WpfMeshCatalog : UserControl, 
	IComponentConnector

The WpfMeshCatalog type exposes the following members.

Constructors
  NameDescription
Public methodWpfMeshCatalog
Initiates a new instance of the control.
Top
Properties
  NameDescription
Public propertyButtonHeight
Gets and sets the height of the button control.
Public propertyButtonText
Gets and sets the text of the button control.
Public propertyButtonWidth
Gets and sets the width of the button control.
Public propertySelectedMeshGrade
The mesh grade in the control.
Public propertySelectedMeshName
The mesh name in the control.
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next