Reinforcement Class

The Reinforcement class represents a reinforcement in the model. A reinforcement can either be a mesh, a single rebar, a rebar group or a strand.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class Reinforcement : ModelObject, 
	IAssemblable

The Reinforcement type exposes the following members.

Properties
  NameDescription
Public propertyClass
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
Public propertyEndPointOffsetType
Gets or sets the type of the end point offset. The options are:
  • OFFSET_TYPE_LEG_LENGTH
  • OFFSET_TYPE_COVER_THICKNESS
Public propertyEndPointOffsetValue
Gets or sets the concrete cover thickness or leg length at the second end of the bar.
Public propertyFather
Gets or sets the father object of the reinforcement; the model object instance to operate on.
Public propertyFromPlaneOffset
Gets or sets the offset value from the part surface.
Public propertyGrade
Gets or sets the steel grade of the reinforcing bar. The grade indicates the strength of the steel used in reinforcing bars. It can also indicate other factors, such as the weldability or surface deformations of the bar.
Public propertyInputPointDeformingState
Gets or sets the reinforcement input point deforming state.
Public propertyName
Gets or sets the name of the reinforcement.
Public propertyNumberingSeries
Gets or sets the numbering series of the reinforcement.
Public propertyOnPlaneOffsets
Gets or sets the double offset value for each leg on the same plane as the bar.
Public propertyRadiusValues
Gets or sets the radius value(s) of the bends in the bar.
Public propertyStartPointOffsetType
Gets or sets the type of the start point offset is either OFFSET_TYPE_LEG_LENGTH or OFFSET_TYPE_COVER_THICKNESS.
Public propertyStartPointOffsetValue
Gets or sets the concrete cover thickness or leg length at the first end of the bar.
Top
Methods
  NameDescription
Public methodGetAssembly
Returns the assembly that the reinforcement belongs to.
Public methodGetFatherPour
Returns the pour that the rebar is associated to.
Public methodGetFatherPourUnit
Returns the pour unit that the rebar is associated to.
Public methodGetNumberOfRebars
Returns the number of rebars in the reinforcing group.
Public methodGetRebarComplexGeometries(Boolean, Boolean, Boolean)
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve rather than a polyline.
Public methodGetRebarComplexGeometries(Boolean, Boolean, Boolean, ReinforcementRebarGeometrySimplificationTypeEnum)
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve (of Arc and LineSegment objects) rather than a polyline. The polycurve only contains arcs if the "simplified" parameter is RATIONALIZED or FABRICATION. If "simplified" is NONE, any arcs will be returned as a series of line segments.
Public methodGetRebarGeometries(Boolean)
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.
Public methodGetRebarGeometries(ReinforcementRebarGeometryOptionEnum)
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.
Public methodGetRebarGeometriesWithoutClashes
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar as shown in model view. In case rebar polygon clashes with itself, physical points are moved to avoid clashing.
Public methodGetSingleRebar
Returns a single rebar inside the rebar group located by the given index. The indexing starts from the start point. The rebar represents a physical reinforcing bar and contains physical points in the 3D space of the bar. The method returns null on error, for example if given an erroneous index. The number of rebars in the group can be requested with GetNumberOfRebars().
Public methodGetSingleRebarWithoutClash
Returns a single rebar inside the rebar group located by the given index. The indexing starts from the start point. The rebar represents a physical reinforcing bar and contains physical, non-clashing points in the 3D space of the bar. The method returns null on error, for example if given an erroneous index. The number of rebars in the group can be requested with GetNumberOfRebars().
Public methodGetSolid
Method for getting the solid information of the reinforcement.
Public methodIsGeometryValid
Tells whether the geometry of a reinforcement object is valid or not.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next