Reinforcement Class

The Reinforcement class represents a reinforcement in the model. A reinforcement can either be a mesh, a single rebar, a rebar group or a strand.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class Reinforcement : ModelObject, 
	IAssemblable

The Reinforcement type exposes the following members.

Properties
  NameDescription
Public propertyClass
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
Public propertyEndPointOffsetType
Gets or sets the type of the end point offset. The options are:
  • OFFSET_TYPE_LEG_LENGTH
  • OFFSET_TYPE_COVER_THICKNESS
Public propertyEndPointOffsetValue
Gets or sets the concrete cover thickness or leg length at the second end of the bar.
Public propertyFather
Gets or sets the father object of the reinforcement; the model object instance to operate on.
Public propertyFromPlaneOffset
Gets or sets the offset value from the part surface.
Public propertyGrade
Gets or sets the steel grade of the reinforcing bar. The grade indicates the strength of the steel used in reinforcing bars. It can also indicate other factors, such as the weldability or surface deformations of the bar.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyInputPointDeformingState
Gets or sets the reinforcement input point deforming state.
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the reinforcement.
Public propertyNumberingSeries
Gets or sets the numbering series of the reinforcement.
Public propertyOnPlaneOffsets
Gets or sets the double offset value for each leg on the same plane as the bar.
Public propertyRadiusValues
Gets or sets the radius value(s) of the bends in the bar.
Public propertyStartPointOffsetType
Gets or sets the type of the start point offset is either OFFSET_TYPE_LEG_LENGTH or OFFSET_TYPE_COVER_THICKNESS.
Public propertyStartPointOffsetValue
Gets or sets the concrete cover thickness or leg length at the first end of the bar.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the instance from the model database.
(Inherited from ModelObject.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAssembly
Returns the assembly that the reinforcement belongs to.
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetFatherPour
Returns the pour that the rebar is associated to.
Public methodGetFatherPourUnit
Returns the pour unit that the rebar is associated to.
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetNumberOfRebars
Returns the number of rebars in the reinforcing group.
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetRebarComplexGeometries(Boolean, Boolean, Boolean)
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve rather than a polyline.
Public methodGetRebarComplexGeometries(Boolean, Boolean, Boolean, ReinforcementRebarGeometrySimplificationTypeEnum)
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve (of Arc and LineSegment objects) rather than a polyline. The polycurve only contains arcs if the "simplified" parameter is RATIONALIZED or FABRICATION. If "simplified" is NONE, any arcs will be returned as a series of line segments.
Public methodGetRebarGeometries(Boolean)
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.
Public methodGetRebarGeometries(ReinforcementRebarGeometryOptionEnum)
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar.
Public methodGetRebarGeometriesWithoutClashes
Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar as shown in model view. In case rebar polygon clashes with itself, physical points are moved to avoid clashing.
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSingleRebar
Returns a single rebar inside the rebar group located by the given index. The indexing starts from the start point. The rebar represents a physical reinforcing bar and contains physical points in the 3D space of the bar. The method returns null on error, for example if given an erroneous index. The number of rebars in the group can be requested with GetNumberOfRebars().
Public methodGetSingleRebarWithoutClash
Returns a single rebar inside the rebar group located by the given index. The indexing starts from the start point. The rebar represents a physical reinforcing bar and contains physical, non-clashing points in the 3D space of the bar. The method returns null on error, for example if given an erroneous index. The number of rebars in the group can be requested with GetNumberOfRebars().
Public methodGetSolid
Method for getting the solid information of the reinforcement.
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the model object instance into the model database.
(Inherited from ModelObject.)
Public methodIsGeometryValid
Tells whether the geometry of a reinforcement object is valid or not.
Public methodModify
Modifies the model instance in the model database.
(Inherited from ModelObject.)
Public methodSelect
Selects the model object instance from the model database.
(Inherited from ModelObject.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next