LoadGroup Class

The LoadGroup class implements grouping functionality related to all loads. Each load should be assigned to a load group. Each load group contains loads caused by the same action and to which you want to refer collectively.

Tekla Structures assumes that all loads in a group

  • Have the same partial safety and other combination factors
  • Have the same action direction
  • Occur at the same time and all together

You may create new load groups, modify existing ones and delete load groups via the .NET interface. You may also change the assigned load group of a load and list all the load groups found in the model via the ModelObjectSelector interface. The model always has at least one load group.

Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LoadGroup : ModelObject

The LoadGroup type exposes the following members.

Constructors
  NameDescription
Public methodLoadGroup
Creates a new load group instance.
Top
Properties
  NameDescription
Public propertyColor
The load group color. This variable indicates the color with which all loads that belong to this same group are drawn in Tekla Structures views.
Public propertyCompatible
This variable is used to store information on which groups are compatible with each other in structural analysis load combination. Load combination is a process in which some simultaneously acting load groups are multiplied by their partial safety factors and combined with each other according to specific rules. To accurately combine loads which have the same load group type, you need to identify which load groups can occur at the same time, i.e. are compatible. This variable stores one integer, and all groups who have this same integer are known to be compatible with each other. Depending on the analysis needs, they may be calculated together, in smaller combinations, or separately.
Public propertyDirection
The load group direction.
Public propertyGroupName
The load group name. The maximum size is 126 characters.
Public propertyGroupType
The load group type.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIncompatible
This variable is used to store information on which groups exclude each other in structural analysis load combination. Load combination is a process in which some simultaneously acting load groups are multiplied by their partial safety factors and combined with each other according to specific rules. To accurately combine loads which have the same load group type, you need to identify which load groups exclude each other, i.e. are incompatible. This variable stores one integer, and all groups who have this same integer are known to be incompatible with each other.
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the load group instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the load group into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing load group in the model database to match the current one. At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a load group from the model database. The ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
Creating a new load group:
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           LoadGroup WindLoads = new LoadGroup();

           WindLoads.GroupName = "ExtremeNorthWind";
           WindLoads.GroupType = LoadGroup.LoadGroupType.EUROCODE_WIND_LOAD;
           WindLoads.Direction = LoadGroup.LoadGroupDirection.DIR_Y;
           WindLoads.Compatible = 2;
           WindLoads.Incompatible = 15;
           WindLoads.Color = LoadGroup.Colors.RED;  

           WindLoads.Insert();
       }
}
Selecting and browsing through all load groups:
using Tekla.Structures.Model;
using System;

public class Example
{
       public void Example1()
       {
           Model Model = new Model();

           ModelObjectEnumerator LoadGroups = 
               Model.GetModelObjectSelector().GetAllObjectsWithType(ModelObject.ModelObjectEnum.LOAD_GROUP);
           foreach (LoadGroup group in LoadGroups)
           {
               Console.WriteLine("Group: " + group.GroupName + "(ID " + group.Identifier.ID + ")");
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next