UserPropertyItemGetOptions Method (ListKeyValuePairString, String, Boolean)

Gets the value options of a string property.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool GetOptions(
	ref List<KeyValuePair<string, string>> StringOptions,
	bool translatedLabels
)

Parameters

StringOptions
Type: System.Collections.GenericListKeyValuePairString, String
The value options.
translatedLabels
Type: SystemBoolean
if set to true labels translated to current language are returned, otherwise the resource key of label is returned.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next