Point Class

The Point class represents a single position in 3D space.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Point : IComparable

The Point type exposes the following members.

Constructors
  NameDescription
Public methodPoint
Instantiates a point with zero members.
Public methodPoint(Point)
Instantiates a point with the given other point.
Public methodPoint(Double, Double)
Instantiates a point with the given coordinates and zero Z-coordinate.
Public methodPoint(Double, Double, Double)
Instantiates a point with the given coordinates.
Top
Methods
  NameDescription
Public methodStatic memberAreEqual
Compares two points and tells whether they are equal.
Public methodCompareTo
Compares two points. To use binarysearch somekind of sorting should be used.
Public methodEquals
Returns true if the current object and the given object are equal.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Returns a hash code for the point. Notice, in extremely rare cases, you might not get the same hash code for two points even though they are considered equal! This should, however, happen only in extremely rare cases!
(Overrides ObjectGetHashCode.)
Public methodToString
Formats the point into a string.
(Overrides ObjectToString.)
Public methodTranslate
Translates the point using the given vector.
Public methodZero
Zeros all the members of the point.
Top
Operators
  NameDescription
Public operatorStatic memberAddition
Returns the sum of the given two points.
Public operatorStatic memberEquality
Compares the given two points for similarity.
Public operatorStatic memberInequality
Compares if the two given points are not similar.
Public operatorStatic memberSubtraction
Returns the difference of the given two points.
Top
Fields
  NameDescription
Public fieldStatic memberEPSILON_SQUARED
A boundary value for comparing if two points are similar.
Public fieldStatic memberHASH_SEED
A default seed value for creating hash codes.
Public fieldX
The X-coordinate of the point.
Public fieldY
The Y-coordinate of the point.
Public fieldZ
The Z-coordinate of the point.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next