Site Class

Class for Building Hierarchy Site
Inheritance Hierarchy

Namespace:  Tekla.Structures.ModelInternal.BuildingHierarchy
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Site : BuildingHierarchyItem

The Site type exposes the following members.

Constructors
  NameDescription
Public methodSite
Initializes a new instance of the Site class.
Top
Properties
  NameDescription
Public propertyDescription
Gets or sets the Description of the Site.
Top
Methods
  NameDescription
Public methodDelete
Deletes the Building Hierarchy object instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodGetBuildings
Gets all buildings belonging to this site.
Public methodInsert
Inserts this Building Hierarchy object into model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing Building Hierarchy object in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects the Building Hierarchy object from model database. The object identifier must be set.
(Overrides ModelObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next