OBBIntersectionWith Method (LineSegment)

Creates an intersection between the OBB and the given LineSegment.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public LineSegment IntersectionWith(
	LineSegment lineSegment
)

Parameters

lineSegment
Type: Tekla.Structures.Geometry3dLineSegment
LineSegment to calculate against

Return Value

Type: LineSegment
Intersection as LineSegment or null if no intersection was found.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the lineSegment parameter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next